NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[resolved] Module version mismatch in dbg-php-5.3.dll


Joined: 15 Aug 2006
Posts: 21
Reply with quote
Hello. I have latest Nusphere (buyed today) and final PHP 5.3 (downloaded today).

dbg-php-5.3.dll throws this error:

Code:
PHP Warning:  PHP Startup: dbg: Unable to initialize module
Module compiled with module API=20090115
PHP    compiled with module API=20090626
These options need to match
 in Unknown on line 0
View user's profileFind all posts by dgxSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
PhpED was released ahead of php 5.3 and we had no clue that the API # will be changed.
At the moment we created php debugger, only RC3 was available. So sorry, if it's not that useful.
We'll provide the modules asap Smile Don't worry.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 03 Nov 2007
Posts: 42
Reply with quote
So we cannot debug PHP 5.3 yet?

_________________
PC
View user's profileFind all posts by computergeniusSend private messageVisit poster's website


Joined: 15 Aug 2006
Posts: 21
Reply with quote
Unfortunately, not fully. Still does not work windows as "Local" or "Watches" while debugging functions or methods.
View user's profileFind all posts by dgxSend private messageVisit poster's website


Joined: 16 Jul 2009
Posts: 15
Reply with quote
hi,

when the working dbg-module will be available?
View user's profileFind all posts by vvbSend private message
debugger 5.3 on windows


Joined: 16 Jul 2009
Posts: 15
Reply with quote
if you're using php on windows make sure you download the VC6 ThreadSafe binaries. the dbg-module doesn't work with VC9-compiled php.
View user's profileFind all posts by vvbSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Quote:
the dbg-module doesn't work with VC9-compiled php


dbg modules work fine with VC9-compiled php. You just need appropriate modules from x86_VC9, x86_NTS_VC9, x86_64, or x86_64_NTS, subdirectories, depending on whether php is threadsafe or not, and your php 32bit or 64bit.
All these modules are available in PhpED version 5.8/5816 and higher.

Quote:
Unfortunately, not fully. Still does not work windows as "Local" or "Watches" while debugging functions or methods.


this was fixed in 5816.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 16 Jul 2009
Posts: 15
Reply with quote
sorry dimitri, of course, you're right...i didn't checked all of the folders in the installation folder.
View user's profileFind all posts by vvbSend private message
[resolved] Module version mismatch in dbg-php-5.3.dll
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic