NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
howto skip sessions


Joined: 09 Mar 2004
Posts: 17
Reply with quote
I was wondering if the skip sessions option is supposed to be working in version 3.3? No matter how far I crank the value up it starts debugging on the first page.

Thanks,
Troy
View user's profileFind all posts by toldroydSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
DBGSESSID=-1 in the link should prohibit debugging even if all other sources including posted values and DBGSESSID value(s) specified in cookies.
if you need to activate a session you'd run
DBGSESSID=nnn[@dbglistenerhost][:port][flags]
where
nnn - is a positive number or zero
flags should be d={0|1};p={0|1};s={number}
d - enable debug session
p - enable profile session
s - skip specified number of requests until real session start (should be 2 or above).
Please note, that if you have images, and/or frames, you'd increase skip number accordingly.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 09 Mar 2004
Posts: 17
Reply with quote
Skip sessions still doesn't seem to be working for me. It still starts debugging on the first line of the page called. I have tried it two ways.

1. In PHPeD under open URL changing the skip sessions value.
2. Calling the page directly from the browser. (ie. http://url/page?DBGSESSID=1500;d=1;s=2

Note: The page that I am calling contains no images or frames.

Thanks for your help
View user's profileFind all posts by toldroydSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
sorry. My mistake.
flags should be delimited with comma, not with semicolon.
For example:
DBGSESSID=1500;d=1,s=10
or if you type directly in the url, please replace = with %3D, like this:
DBGSESSID=1500;d%3D1,s%3D10
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 09 Mar 2004
Posts: 17
Reply with quote
Ok...it's working now for me entering it directly into the browser.

Is it a bug from within the IDE because it is not passing the skip flag when you use open url and add a skip sessions value? All the other flags seem to work properly.

Thanks for your help
View user's profileFind all posts by toldroydSend private message
howto skip sessions
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic