NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
XAMPP, debugger and "Apache HTTP Server has stopped wor


Joined: 22 Jun 2007
Posts: 12
Location: SF
Reply with quote
Hi Dear all:

Recently I upgraded my local development environment from running earlier version of XAMPP lite (1.6.x I guess) with PhpED 5.2, to XAMPP lite (1.7.0) with PhpED 5.6. Of course I also replace the zend_extension_ts="C:\amp\php\ext\dbg-php-5.2.dll" in the php.ini under apache bin, everything seems to work fine. However, I'm experiencing some random Apache crash after I upgraded to the new software. When apache crash, it will show me this error message:

Apache HTTP Server has stopped working
Windows is checking for a solution to the problem...

Then I did some google search, found this discussion thread:
http://www.google.com/search?q=Apache+HTTP+server+has+stopped+working

So this thread is suggesting that we should disable any non-required modules in PHP. I'm not sure whether this is referring to the new ext\dbg-php-5.2.dll that I added to the php.ini. Anyone experienced this problem wtih XAMPP lite 1.7.0 and PhpED 5.6?? Here are my detailed config:

OS: Windows Vista Enterprise, 32-bit

###### ApacheFriends XAMPPlite Version 1.7.0 ######
+ Apache 2..2.11
+ MySQL 5.1.30 (Community Server)
+ PHP 5.2.8
+ XAMPPlite Control Version 2.5 from ApacheFriends
+ XAMPPlite Security 1.0
+ SQLite 2.8.15
+ OpenSSL 0.9.8i
+ phpMyAdmin 3.1.1
+ Webalizer 2.01-10
+ Zend Optimizer 3.3.0
+ eAccelerator 0.9.5.3 for PHP 5.2.7 (comment in php.ini)
+ dbg-php-5.2.dll (from NuSphere), also modified the php.ini as instructed)

I do not run any anti-spyware or anti-virus software in the background so I don't think they ware related to the crash, all I can think of is either the new XAMPP lite 1.7.0 has some sort of bug by itself, or the dbg-php-5.2.dll somehow has some conflict with this particular XAMPP lite, or the dbg-php-5.2.dll has some bug... Anyway, any help would be highly appreciated. Thanks!
View user's profileFind all posts by chuangSend private messageVisit poster's websiteAIM AddressYahoo MessengerMSN Messenger
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
try to disable the two below
+ Zend Optimizer 3.3.0
+ eAccelerator 0.9.5.3 for PHP 5.2.7 (comment in php.ini)

eAccelerator is known to crash apache.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
XAMPP, debugger and "Apache HTTP Server has stopped wor
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic