NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
debugger.hosts_allow for DHCP


Joined: 17 Oct 2007
Posts: 4
Reply with quote
I installed dbg on my remote server and according to dbg-wizard.php and phpinfo, it seems to have been installed correctly. My project root directory is pointed to a networked drive, which is networked using Samba.

When I try to start the debugger, I get the following error:
Failed to start DBG session


Reason: connection to the client address 192.168.1.1:7869 is not allowed
Not sure what it means? Visit http://www.nusphere.com/dbg/ for troubleshooting.

Debugger request: "1@192.168.1.1:7869;d=1,p=0"
Request found in: "$_COOKIE['DBGSESSID']"
Target PHP version: "5.1.4"
Server API: "Apache 2.0 Handler"
Extensions API: "220051025"
Modules API: "20050922"
PHP API: "20041225"

I see others have posted this error message, but my php.ini file already have the following:
debugger.hosts_allow = 192.168.1.1
debugger.ports=7869, 10000/16

I'm not sure if 192.168.1.1 is the right address to use as that is my default gateway address. I am using DHCP, but I've also tried 192.168.1.101. Screen shot of my ipconfig is included below:




Please help.
Thanks.
View user's profileFind all posts by chuenderSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
Quote:
Reason: connection to the client address 192.168.1.1:7869 is not allowed

it means that either this address or this port or both are not allowed.

Quote:
I see others have posted this error message, but my php.ini file already have the following:
debugger.hosts_allow = 192.168.1.1
debugger.ports=7869, 10000/16

debugger may not see these lines if they are above the debugger loading statement (a kind of bug in php itself) or if you added them to wrong php.ini file that is not used at all or it is used too early, before loading dbg.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 17 Oct 2007
Posts: 4
Reply with quote
Hi dmitri,


These lines are below the debugger load statement and are in the right php.ini file. what else coudl be causing this?
View user's profileFind all posts by chuenderSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
Nothing else. I'd recommend to double check everything.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Wierd behavior


Joined: 05 Sep 2007
Posts: 4
Location: San Diego, CA
Reply with quote
I have the same problem, although debugging does work... sort of.

DBG 3.4.1

Failed to start DBG session


Reason: connection to the client address 192.168.1.1:7869 is not allowed
Not sure what it means? Visit http://www.nusphere.com/dbg/ for troubleshooting.


Debugger request: "39897964954100052localhost;d=1,p=0,c=1"
Request found in: "query_string"
Target PHP version: "5.2.x"
Server API: "Apache 2.0 Handler"
Extensions API: "220060519"
Modules API: "20060613"
PHP API: "20041225


192.168.1.1 is my gateway, and my client is actually 192.168.1.109 which works fine if I debug though several blocks of code. I'm using SSH and my php.ini says allow=localhost, nothing else. But for some odd reason, while stepping though large blocks of code such as WordPress, it suddenly gives way and spits out this message. I'm perplexed as to why its choosen the gateway IP of all IPs. If I fail to start my SSH session it does error out correctly with 192.168.1.109:7869 not allowed. But then why the gateway in the middle of a debug session? Any thoughts?
View user's profileFind all posts by SteveorevoSend private messageAIM AddressYahoo MessengerMSN Messenger
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
Quote:
Reason: connection to the client address 192.168.1.1:7869 is not allowed


So, allow it. Why you didn't?

Quote:
I'm using SSH and my php.ini says allow=localhost, nothing else


Localhost is a correct setting in most cases. But it's not correct if you connect ssh to one host (aka gateway) and use it to debug another.
In this case gateway's IP should be allowed in php.ini and it's gateway's IP should be entered in the debugger host setting.
For example, if you run ssh and login to 192.168.1.1, you have to allow 192.168.1.1 in php.ini and you have to enter 192.168.1.1 as a debugger host.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
debugger.hosts_allow for DHCP
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic