NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
TIP: Non-english characters in PhpED 3.2 FOR LINUX
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Quote:
I can't enter {russian|french|etc} characters in PHPED


Below is a description of what steps should be performed in order to get russian characters show. Please substitute appropriate values for the other languages.

CASE #1 Mandrake 9.1, KDE 3.1

1.
edit file /etc/profile
add at the end of file:
export LANG=ru_RU.KOI8-R
export LC_ALL=ru_RU.KOI8-R


then Reboot Linux

2.
Configuration -> Other -> LocalDrake
set Russian

3.
Configuration -> Control Center -> Accessibility -> Country - Region & Language
add Russian language. Make sure that English language is listed there also as you probably want to type latin characters too, not only Russian ones.

4.
Configuration -> Control Center -> Accessibility -> Keyboard Layout
Enable keyboard layout
set Additional layout "Russian"
(check that U.S.English is there too)

5.
PhpEd -> Settings -> Editor
set Character set to KOI8-R


CASE #2 RedHat 7.2 KDE 2.2

1.
edit file /etc/profile
add to end of file:
export LANG=ru_RU.KOI8-R
export LC_ALL=ru_RU.KOI8-R


then Reboot Linux

2.
KDE Control Center -> Look&Feel -> Fonts
set character set for all fronts to KOI8-R

3.
KDE Control Center -> Personalization -> Country & Language
set Charset to KOI8-R

4.
KDE Control Center -> Peripherals -> Keyboard
turn on Additional layout "Russian". Check that U.S.English is added too

5.
PhpEd -> Settings -> Editor
set Character set to KOI8-R


CP1251 case
in case of CP1251, set up LC_ALL as ru_RU.CP1251,
but PhpEd should be set with font code page KOI8-R. See Settings -> Editor, Code page.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
TIP: Non-english characters in PhpED 3.2 FOR LINUX
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic