NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Wrong dbg version


Joined: 26 Feb 2004
Posts: 6
Reply with quote
Linux trial of PHPed comes with dbg 2.14 latest free version is 2.11 but latest windows trail of phped is looking for 2.16.

I have dbg 2.14 installed on my linux server and Phped 3.3 installed on my windows desktop. when I try to debug form phped I get "Failed to start debugger session (timeout)" but when I add "?DBGSESSID=0@clienthost:7869" to the end of my script in IE I get "Wrong Version (2.14) of debugger module detected on the server side. Debugger module version of 2.16 is needed to start debug session." where do I get 2.16 of dbg for linux??
View user's profileFind all posts by agoughSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7875
Reply with quote
Hmm, where did you take dbg-2.14 for linux then ?
Actually, you're correct phped 3.3 comes with 2.16 Smile
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 26 Feb 2004
Posts: 6
Reply with quote
on http://www.php-debugger.com/dbg/ the latest version is 2.11 so I downloaded the linux eval of PHPed and installed it then I copied dbg.so-4.3.3 from /usr/local/nusphere/phped/php/extensions to my php/apache2 extenstions directory and added it to my php.ini and it loaded as 2.14.

So how do I get hold of 2.16 for linux??? SO I can use it from phped on windows?
View user's profileFind all posts by agoughSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7875
Reply with quote
If you work with phped for Windows why did you take one for linux ?
What comes with phped/windows download is a full version and does not require anything else. It has modules for many platforms including Linux.
Wink
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 26 Feb 2004
Posts: 6
Reply with quote
Embarassed Doh! just me being stupid. I didn't realise that phped for windows bundled in dbg for linux. organally I sourced dbg form the www.php-debugger.com site and then as a last ditched attempt grabbed the linux phped trial. but got the right .so from my windows phped install directory and its working sweet. Very Happy
View user's profileFind all posts by agoughSend private message
Wrong dbg version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic