NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Will encoded for PHP 4.4 run on PHP 5.2?


Joined: 08 Jul 2008
Posts: 8
Reply with quote
When a script encoded for PHP 4.4 calls a method statically, I get the error:

Fatal error: Failed to load encoded file (index.php) unexpected fetch opcode (113) in index.php on line 0

I get this error if I attempt to run the encoded script in a PHP 5.2 setup. The error won't appear if I run the script in a PHP 4 setup. It also won't appear if I remove the static calls, even if I encode it for PHP 4 and run it in PHP 5. Now, why would I do that, you ask? Well, I don't want to maintain two versions of the application (one encoded for PHP 4 and one for PHP 5). I want to encode the application for PHP 4 and then users should be able to run it on both PHP 4 and 5 setups.

Is this possible?
View user's profileFind all posts by MikaelSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Hmm, I'm not sure if you got my private msg.
Scripts, encoded for 4.4 will run under 4.4, 5.0, and any version above 5.0, including 5.2.
If you can replicate the problem using the latest version of nucoder and phpexpress, please contact NuSphere support and provide all the details.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Will encoded for PHP 4.4 run on PHP 5.2?
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic