NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Strange problem with stepping through code


Joined: 26 Feb 2004
Posts: 1
Reply with quote
Hi,
I'm currently running PHPEdit 0.8.25 with the supplied version of DBG and PHP and have experienced the following strange behaviour. When setting breakpoints it appears that I can set one in embedded HTML code and indeed, the current code point marker seems to jump into the HTML when step-debugging.

I've tried a number of approaches. I've checked the line-ending types, tried different versions of DBG, PHP, and even tried the trial version of PHPed - the problem still occurs. It is independant of whether or not PHP is running as a CGI or an Apache2 module. I can only conclude that it is one of two things: my code (which I'm willing to add to this post if needs be) or DBG itself.

The problem did not show up when I wrote some similarly structured code in PHPEdit itself (I don't know if this is relevant).

I hope you can help.

Many thanks for an otherwise great product.
View user's profileFind all posts by turveyspSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
All your HTML code is actually converted to series of echos and because of that you can step through them.
It's sepecific to php itself. Smile
Neither dbg nor IDE are involved.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Strange problem with stepping through code
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic