NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Zend debugger and PHPed debugger (2.14) conflict - Resolved


Joined: 16 Jan 2004
Posts: 6
Reply with quote
Is there a conflict when trying to run the debugger bundled with the Zend IDE and the PHPed debugger? If I try to run both, I get the following error in Apache logs:

PHP Warning: Function registration failed - duplicate name - zend_loader_enabled in Unknown on line 0

I am running Windows XP, Apache 1.3.28, PHP 4.3.3, all on a local machine.

Thanks,

--
Jim
View user's profileFind all posts by jthomeSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
What DBG version have you installed ? Please check phpinfo.

BTW, Smile what's the advantage of having them both installed simultaneously ?

Dmitri.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Debug version


Joined: 16 Jan 2004
Posts: 6
Reply with quote
Debug version: 2.14.10


>>BTW, what's the advantage of having them both installed simultaneously?

I wouldn't say it's an advantage; I use both IDE's interchangeably because there are things I like (and don't like) about each one. As far as the debugger goes, I don't like having to define a workspace/project just to launch the remote debugger in PHPed (if I don't have to, I'd sure like to know how.) I don't have to do this in Zend.

--
Jim
View user's profileFind all posts by jthomeSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
You'd give phped 3.3 a try...
I hope it has no conflict with other zend extensions like their debugger.
I fixed some stuff that would make dbg-2.16 running better. Not yet tried with zend.
Please let me know about the results.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
PHPed 3.3


Joined: 16 Jan 2004
Posts: 6
Reply with quote
Am I able to download and install with my current license?
View user's profileFind all posts by jthomeSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
Good question.

First, please install 3.3 into a different directory, update dbg module for the server then make experiments (whatsoever).
When you decide to switch back to 3.2 (or 3.2.1) you'll have to
1) uninstall trial version 2) revert back debugger module and 3) re-register debugger 2.14.10 with the following commands:

Code:
cd "c:\program files\nusphere\phped\debugger"
regsvr32 PHPDbgPS.dll
DbgListener.exe -RegServer


I assumed that phped 3.2 is installed in c:\program files\nusphere\phped directory. Substitute accordingly if it differs from yours.

Dmitri.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Fixed


Joined: 16 Jan 2004
Posts: 6
Reply with quote
Sorry for the late reply, but I got side tracked on something else.

Just wanted to make sure the loop is closed on this topic. Changing to PHPed v. 3.3 fixed the problem, although I had some mapping issues that I needed to sort through. Once I had all the directories properly mapped, everything worked fine.

Thanks for quick response and help.

--
Jim
View user's profileFind all posts by jthomeSend private message
Zend debugger and PHPed debugger (2.14) conflict - Resolved
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic