NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
It's (not) necessary to update DBG client error? help :)


Joined: 08 Mar 2008
Posts: 7
Reply with quote
Hi

On the remote Ubuntu server:

Code:
# uname -a
Linux MyServer 2.6.18-xen #1 SMP Tue Feb 12 06:40:50 UTC 2008 x86_64 GNU/Linux


running PHP 5.2.4:

Code:
# php -v
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/imagick.so' - libWand.so.10: cannot open shared object file: No such file or directory in Unknown on line 0
PHP 5.2.4-2ubuntu5.1 with Suhosin-Patch 0.9.6.2 (cli) (built: May  9 2008 16:54:00)
Copyright (c) 1997-2007 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with DBG v3.2.10, (C) 2000,2007, by Dmitri Dmitrienko


Ignoring the imagick.so error, please could you help me fix the following error?

Quote:
DBG 3.2.10

Failed to start DBG session


Reason: debugger module is called from an old or incompatible client software. It's necessary to update DBG client (dbglistener) to version 3.2.10 or higher
Not sure what it means? Visit http://www.nusphere.com/dbg/ for troubleshooting.

Debugger request: "396357724048700002@localhost;d=1,p=0,c=1"
Request found in: "query_string"
Target PHP version: "5.2.x"
Server API: "Apache 2.0 Handler"
Extensions API: "220060519"
Modules API: "20060613"
PHP API: "20041225"



My DBG Listener version (on the local windows XP development PC) is version 3.2.9, so this checks the box that was apparently wrong.

I followed this guide, installing CYGWIN and setting up a SSH tunnel:

Code:
ssh -R localhost:7869:my_server_ip:7869 chris@my_server_ip -p my_server_SSH_port


which logs into the server properly (do I need to do more than this?)

also, I've ticked the box in PhpEd "Use custom port and host", as the guide told me to.

Any ideas why I'm getting the above error? I've done quite a bit of research but can't seem to fix the error.


Cheers,
Innus


Last edited by Innus on Tue Jul 08, 2008 3:43 pm; edited 1 time in total
View user's profileFind all posts by InnusSend private message


Joined: 08 Mar 2008
Posts: 7
Reply with quote
anybody? Smile
View user's profileFind all posts by InnusSend private message
Veteran

Joined: 06 Jun 2007
Posts: 289
Location: Vancouver, Canada
Reply with quote
Innus, the error says you should use the DBG client (dbglistener) version 3.2.10 or higher, and you state that you are using version 3.2.9. Does that not explain the problem?

PS: I suspect your SSH tunnel is working fine because it seems like your DBG client and server are indeed communicating.

_________________
Smile
View user's profileFind all posts by annoSend private messageVisit poster's website


Joined: 08 Mar 2008
Posts: 7
Reply with quote
Hmmm.

Indeed.

Fairly embarressed I didnt notice that myself. Apparently I misread that for an entire night.

Ah well, fixed now :S

Thanks for that!
View user's profileFind all posts by InnusSend private message


Joined: 08 Mar 2008
Posts: 7
Reply with quote
Ok, scrap that: still getting the same error message.


I installed the latest version of nusphere phped (and as a result have DBG Listener 3.2.14 installed and running too.)

After connecting using SSH via cygwin:

Quote:
ssh -R localhost:7869:my_server_ip:7869 chris@my_server_ip -p my_server_SSH_port


I get the following error message:


Quote:
DBG 3.2.10

Failed to start DBG session


Reason: debugger module is called from an old or incompatible client software. It's necessary to update DBG client (dbglistener) to version 3.2.10 or higher
Not sure what it means? Visit http://www.nusphere.com/dbg/ for troubleshooting.

Debugger request: "396414855844900005@localhost;d=1,p=0,c=1"
Request found in: "query_string"
Target PHP version: "5.2.x"
Server API: "Apache 2.0 Handler"
Extensions API: "220060519"
Modules API: "20060613"
PHP API: "20041225"


I repeat that I do have DBG Listener 3.2.14 installed and running.


Here is what I added to php.ini:
Quote:
extension=dbg.so-5.2.x
[debugger]
debugger.hosts_allow= 77.98.197.227 localhost 127.0.0.1
debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16


Here is what's ports are being listened to
Quote:
ServerName /etc/php5/apache2: netstat -an | grep "LISTEN "
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:7869 0.0.0.0:* LISTEN
tcp6 0 0 :::1925 :::* LISTEN
tcp6 0 0 ::1:7869 :::* LISTEN


note that it does have the line:
Quote:
tcp6 0 0 ::1:7869 :::* LISTEN


does that line look right?



Here is my firewall policy:
Quote:
ServerName /etc/php5/apache2: sudo iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
View user's profileFind all posts by InnusSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Quote:
Reason: debugger module is called from an old or incompatible client software. It's necessary to update DBG client (dbglistener) to version 3.2.10 or higher

in case of SSH tunnel, you can safely interpret this error message as if it was telling you that the tunnel does NOT work.


Quote:
ssh -R localhost:7869:my_server_ip:7869...

you need ssh -R localhost:7869:localhost:7869

Quote:
tcp6 0 0 ::1:7869 :::* LISTEN

It makes very little sense as ipv6 is not supported at the moment.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
It's (not) necessary to update DBG client error? help :)
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic