NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[resolved] DB Client and mysql connection


Joined: 10 Feb 2007
Posts: 48
Reply with quote
After installing Nusphere's TechPlat on my XP Pro system, I've configured PhpED to use the newly installed Apache/PHP for 'Projects'.

Installed MySQL and replaced all previous versions of 'libmysql.dll' (used by TechPlat and PhpED) with the one that came with MySQL. According to phpinfo(), MySQL appears to be installed and running okay. However, there are some questions. In both the Local Value and Master Value the following directives have 'no value':

mysql.default_host......no value
mysql.default_password......no value
mysql.default_port......no value
mysql.default_socket......no value
mysql.default_user......no value

Do any of the above directives need to have values?

Using DBTools manager successfully set up a user, a database, and a table with a couple of fields.

The problem is setting up the 'DB Client' in PhpED Pro.

After setting up the DB Client connection, then clicking on the plus sign next to the database (that appears beside the database when DB Client is opened) this error message appears:

Quote:
SQL Server Error: [DBNETLIB][ConnectionOpen (ParseConnectParams()).]Invalid connection.


What am I overlooking that could generate this error? What's the next step?


UPDATE:
-------------------------------------------------------------------------------------------------------
I can access MySQL with a PHP program to connect to the database.

It seems that the problem is how I'm configuring DB Client. Any help is appreciated.
View user's profileFind all posts by StorymanSend private message


Joined: 10 Feb 2007
Posts: 48
Reply with quote
Can someone let me know if these connection settings look correct (for DB Client).

Hostname or IP address.................localhost
Port..............................................3306
Initial database..............................test
Login Name....................................rich
Password.......................................xxxx
Save password checked.
View user's profileFind all posts by StorymanSend private message
Veteran

Joined: 06 Jun 2007
Posts: 289
Location: Vancouver, Canada
Reply with quote
Storyman, those settings appear fine to me. The only issue I can think of is that you should update the libmysql.dll in your C:\Program Files\Nusphere\PhpED folder with the one that came with your MySQL Server installation. But you do state that you have done that; maybe do it again to be sure.

_________________
Smile
View user's profileFind all posts by annoSend private messageVisit poster's website


Joined: 10 Feb 2007
Posts: 48
Reply with quote
Anno, thanks for confirming that everything appears copacetic. As per your suggestion re-copied libmysql.dll to the appropriate directories. In fact replaced every copy of libmysql.dll with the one that came with MySQL. Same result.

Shutting down the anti-virus program and firewall gives is no relief.

Are there any additional elements that might effect DB Client and keep it from working?

As mentioned previously 'mysql_connect' does work. It would be nice to be able to get DB Client to work. I'm really stumped and have no idea of what to test next.
View user's profileFind all posts by StorymanSend private message


Joined: 10 Feb 2007
Posts: 48
Reply with quote
Now Working.

Deleted the Database account set up initially, then added a new one from scratch.
View user's profileFind all posts by StorymanSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
obviously you had mssql connection, not mysql one. It's only mssql may warn about [DBNETLIB].

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
[resolved] DB Client and mysql connection
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic