NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
PHP Debugger error using Wine and OS X Leopard


Joined: 26 Jun 2008
Posts: 2
Reply with quote
Hi,

I am using a MacBook Pro running Leopard 10.5.3 and the latest version of WINE.

On startup of PHPEd I get the following error:
Failed to load php debugger client library. Please reinstall the product

Does anyone know how to remedy this and get the debug listener working with WINE on OS X?

Thanks,
Mike
View user's profileFind all posts by desaroSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
It looks like somewhere in between 0.9.49 and 1.0, Wine got a kind of regression in their COM inter-process communcation. To remedy the problem, you need to run dbglistener.exe prior to phped.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 26 Jun 2008
Posts: 2
Reply with quote
Hi Dmitri,

I tried running Dbglistener.exe prior to PHPEd and the listener starts up without error. When starting PHPEd I get the same error as before though:
'Failed to load php debugger client library. Please reinstall the product'

Any ideas?

Thanks in advance,
Mike
View user's profileFind all posts by desaroSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Quote:
Any ideas?

I think that Wine guyes did something wrong with RPC4 layer. Looks like since v0.9.50 released the proxy/stub dll isn't working anymore.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
PHP Debugger error using Wine and OS X Leopard
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic