NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Debugging with Delphi4php


Joined: 01 Jul 2008
Posts: 3
Reply with quote
Hello,

please forgive me if my technical terms are not precise.

Trying to search on your website I understand that Delphi for php uses PHP DBG from nusphere as a debugger. I just downloaded the trial version of Delphi4php since I was a Delphi for windows (Delphi 2.0) and a VCL fan. I need to mantain and make some changes on my website (www.mdsrl.it).

I'm trying to debug a php file that belongs to "oscommerce" (my website is based on oscommerce), but I have some problem:

if I try to debug and run the first file (default.php) it all works very well and I'm able to watch clearly everything.

When I need to go on and try to debug a page (a file) called by default.php following a link on the browser, the debugger doesn't stop where I put the breakpoint.

For example, in delphi4php IDE I open default.php and product_info.php and I put a breakpoint in product_info.php.

I start debugging default.php and then I choose a link on the browser that point to product_info.php but the debugger doesn't stop at the breakpoint I gave.

Of course the links doesn't include parameters like

restore_session or DBGSESSID or the port 7869

I think that I'm missing something ... can you help me?

thank you
Francesco
View user's profileFind all posts by datawareSend private message


Joined: 01 Jul 2008
Posts: 3
Reply with quote
Update:

I forget to tell you that I installed XAMPP and Apache server was always running during my debug sessions.

Now I stopped Apache Server from XAMPP control panel and I restarted the pc. Doing this way, I think that Delphi for php will use the internal apache server for debugging.

Now loading the page, even if no breakpoint is reached, is much more slower, images are missing and trying to click on any link on the "debugged webpage" will produce an "Impossibile Visualizzare la Pagina" error in IE (in English is something like "Impossible to visualize the webpage").

The address on wich I debug the default.php page is:

http://localhost:3570/default.php?restore_session=1&DBGSESSID=1@clienthost:7869

And the address where I get the error is:

http://localhost/devmdsrl/catalog/default.php/cPath/1?osCsid=gga2vnac3n2q8bj7jbechcj896

As you can see there is always a lack of parameters for the debugger.
View user's profileFind all posts by datawareSend private message


Joined: 01 Jul 2008
Posts: 3
Reply with quote
Ok, tried PHPED, no VCL, no visual RAD tools but debugger works very well. If I have to choose between debugger and VCL + RAD, for this moment, I prefer the debugger.
View user's profileFind all posts by datawareSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Quote:
I prefer the debugger.

Thanks.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Debugging with Delphi4php
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic