NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Problem with postrgress library - libpq.dll - in build 5236
Veteran

Joined: 24 Jan 2006
Posts: 311
Reply with quote
Postgress library required a new build, which didn't make it into 5236.

To use PostgreSQL please download the following link:
http://forum.nusphere.com/sshot/libpq20080512.zip

Unzip it and place libpq.dll in c:\program files\nusphere\phped overriding the one in place now


New libpq.dll will be included in upcoming new build of PhpED

We apologize for any inconvenience it might have caused. Thank you!
View user's profileFind all posts by yfaktorSend private message


Joined: 14 Apr 2008
Posts: 10
Reply with quote
Sorry, but this did not solved the problem. I continue having a message saying that LibPQ.DLL is not found.

regards
octal
View user's profileFind all posts by octalSend private message
Veteran

Joined: 24 Jan 2006
Posts: 311
Reply with quote
Hi - could you please make sure that c:\program files\nusphere\phped has new libpq.dll? To be sure - can you please delete the existing file and copy the new one again?
Thank you!
View user's profileFind all posts by yfaktorSend private message
Veteran

Joined: 24 Jan 2006
Posts: 311
Reply with quote
Additional information: PHP changed the way they linked libpq.dll, so we updated the build of PHP distributed with PhpED - the problem with libpq.dll is caused by this. We apologize once again for this inconvenience and ask that you install this PHP build:
http://forum.nusphere.com/sshot/NuSphere-phped-5.2-php5.2.6-Win32.exe

Many thanks for your patience.
View user's profileFind all posts by yfaktorSend private message


Joined: 14 Apr 2008
Posts: 10
Reply with quote
Sorry but again didnt worked.

1- I deleted manually libpq.dll and checked all other folders for such dll and I did not found any. I copied downloaded dll and it still continue to say LIBPQ.DLL is not found.
2- I uninstalled completely PHPEd and I deleted completely NUSPhere folder from "Program Files". I installed last xxx237 version (I downloaded it from my account in reg users area). And I have the same problem Sad

3- I got back to xxxx235 and it worked fine.

regards
octal


PS. I'm using an Athlon XP3000+ PC under Windows XP+SP2 with all last updates and 1,5GB RAM and about 200GB free disk space.
View user's profileFind all posts by octalSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Quote:
Sorry but again didnt worked.

Sorry, but your steps do not list installing php from the link that Yury posted in this thread.
Please INSTALL it first.
You don't have to reinstall PhpED at all.

For further details on the php bug, please check this issue:
http://bugs.php.net/bug.php?id=44905
unable-to-locate-libpq-dll-in-5236-5237-build-t4848.html

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Problem with postrgress library - libpq.dll - in build 5236
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic