NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Can't get phpED to communicate with DBG


Joined: 14 Feb 2004
Posts: 6
Reply with quote
Hi!

I'm developping a PHP website that is stored on a Debian server with the following software: Apache/1.3.26 PHP/4.1.2.
However, I develop the software on my own machine running XP using phpED 3.2.1 (build 3239).

I installed DBG on the Debian server, with the following lines in the php.ini
[debugger]
debugger.enabled = true
debugger.profiler_enabled = true
debugger.JIT_host = localhost
debugger.JIT_port = 7869
debugger.host = localhost
debugger.port = 7869

I then established an SSH tunnel using PuTTy that forwards the port 7869 to my localhost:7869, and have the DBGlistener configured to listen on port 7869 (IP address is 192.168.0.2, as it is behind another server/gateway with NAT)

When I then try to debug a script from phpED, it says "Waiting for debug session" and finally stops with a timeout message.
When trying from the browser using ...?SESSID=0&localhost:7869, it returns a
Code:
DBG
Failed to start debug session
reason:
failed to establish connection to client host on localhost:7869


The reason I'm using an SSH tunnel is that the webserver is fairly protected and I'm already using SSH tunnels for a lot of things.

I was actually able to use clienhost instead, changing the values in the php.ini and removing the SSH tunnel. I needed to open the port 7869 on my server/gateway and it then worked, but this is not ideal. I'd like to be able to use the SSH tunnel instead.

Any idea why it doesn't work?
View user's profileFind all posts by WabilooSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
after you set up a tunnel you'd verify if socket is really forwarded by running the command below in the tunnel console:
Code:
netstat -nao|grep 7869

If you don't see this socket listening on the server, you have to check putty settings.
If the socket is opened and in listening state, you'd check your firewall settings which should allow local connections on 7869th port.
To prove that DBG itself is not involved you'd check by involking the command below in the tunnel console:
Code:
telnet localhost 7869

I think you'll get exactly the same timeout.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Can't get phpED to communicate with DBG
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic