NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Transliteration error


Joined: 05 Sep 2015
Posts: 7
Reply with quote
Hi,
I have an issue with PhpEd IDE 15.0 (Build 15012, 64bit)

1. My PHP files in WINDOWS-1251 encoding
2. In IDE settings I selected default file encoding WINDOWS-1251.

When I'm trying to make search in files, I'm getting error "Failed to open file"

When I trying to open some file in IDE, I'm getting error: Transliteration error

When I manually select WINDOWS-1251, I can view/edit my file.

I did try to set default file encoding to LATIN1 - got same error
I did try to set default file encoding to UTF-8 - got same error

What I'm doing wrong?

Thanks,
Lev

IDE settings


Search errors


File open error


File open fix
View user's profileFind all posts by klevSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
It only means that IDE remembered that you opened this file with UTF-8 once in the past.
IDE will update its records as soon as you open it in a different charset. No problems so far.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 05 Sep 2015
Posts: 7
Reply with quote
dmitri wrote:
It only means that IDE remembered that you opened this file with UTF-8 once in the past.
IDE will update its records as soon as you open it in a different charset. No problems so far.


Hi dmitri,
I did check your point.
Your solution works when I press "Transliterate" button. Then the IDE remember the file encoding.
If I choose "OK" button, IDE show the file, but I see the "Transliteration error" each time, when I open the file again.

Can you explain the differences?

SVN recognize no changes in the file.

My second issue, the file search will not search inside files, until I "Transliterate" every file in a project.

Is there any option to "Transliterate" every file in a project or tell search module, do not stop on unknown file encoding and search inside as ASCII file?

Thanks,
Lev
View user's profileFind all posts by klevSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
what you showed are IDE-wide setting. What's about 2 other settings: encoding settings for the project and for the directory?

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 05 Sep 2015
Posts: 7
Reply with quote
dmitri wrote:
what you showed are IDE-wide setting. What's about 2 other settings: encoding settings for the project and for the directory?


Didn't know about project / directory encoding.

Thanks.
The search is working now.
View user's profileFind all posts by klevSend private message
Transliteration error
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic