NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Unable to consume a .Net Web Service using https


Joined: 06 Feb 2004
Posts: 1
Location: Englewood, CO
Reply with quote
It works fine using http. When I get to change the URL to https, it gives me the following eror:

Warning: fread() [function.fread]: SSL: fatal protocol error in /var/apps/apache/web_docs/includes/nusoap.php on line 1777
Fatal error: Maximum execution time of 30 seconds exceeded in /var/apps/apache/web_docs/includes/nusoap.php on line 1778


Below some relevant information:
***************************************
I am using nusoap.php version: * @author Dietrich Ayala <dietrich@ganx4.com>
* @version v 0.6.5
***************************************
This is an excerpt from phpinfo():
PHP Version 4.3.1

System SunOS webtest 5.9 Generic_112233-11 sun4u
Build Date Jan 22 2004 11:31:25
Configure Command './configure' '--prefix=/var/apps/php4' '--with-apache=/var/tmp/apache_1.3.27' '--with-openssl=/usr/local/ssl' '--with-curl=/var/apps/curl' '--enable-apxs' '--with-ldap'
Server API Apache
Virtual Directory Support disabled
Configuration File (php.ini) Path /var/apps/php4/lib
PHP API 20020918
PHP Extension 20020429
Zend Extension 20021010
Debug Build no
Thread Safety disabled
Registered PHP Streams php, http, ftp, https, ftps


APACHE_INCLUDE no value
APACHE_TARGET no value
Apache Version Apache/1.3.27
Apache Release 10327100
Apache API Version 19990320
Hostname:Port webtest.jones.com:80
User/Group www-user(3000)/3000
Max Requests Per Child: 0 - Keep Alive: on - Max Per Connection: 100
Timeouts Connection: 300 - Keep-Alive: 15
Server Root /var/apps/apache
Loaded Modules mod_php4, mod_ssl, mod_setenvif, mod_so, mod_unique_id, mod_usertrack, mod_headers, mod_expires, mod_cern_meta, mod_proxy, mod_digest, mod_auth_dbm, mod_auth_anon, mod_auth, mod_access, mod_rewrite, mod_alias, mod_userdir, mod_speling, mod_actions, mod_imap, mod_asis, mod_cgi, mod_dir, mod_autoindex, mod_include, mod_info, mod_status, mod_negotiation, mod_mime, mod_mime_magic, mod_log_config, mod_define, mod_env, mod_vhost_alias, http_core


curl
CURL support enabled
CURL Information libcurl/7.10.8 OpenSSL/0.9.7c zlib/1.1.4



Any idea why it wouldn't work

Thank you!

Ricky
View user's profileFind all posts by RickyschSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
To work using HTTPS you need nusoap 0.7 that comes with PHPED 3.3
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Unable to consume a .Net Web Service using https
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic