NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[resolved] Failed to start debug, phped 4.6


Joined: 12 Oct 2007
Posts: 1
Reply with quote
I am running:
PhpED: Version 4.6.3 (Build 4635)
System: Windows Vista Business
Apache: 2.2.3
PHP: 5.2.0

I copied php_dbg.dll-5.2.x from my Phped installation, C:\phped\debugger\server\Win32\x86\, to my php ext directory (C:\php\ext)

I setup php.ini as follows:
(any line with zend has been commented out)
extension=php_dbg.dll-5.2.x

[debugger]
debugger.enabled=on
debugger.profiler_enabled=on
debugger.hosts_allow=localhost
debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16

I get the following output in php info which indicates degguer is installed:
DBG php debugger, version 3.1.9, Copyright 2001, 2006 Dmitri Dmitrienko, http://www.nusphere.com/dbg

But when I select "Run in Debugger" option in PhpED, I get the following error:
"Failed to start debug session (error:2)Please make sure that debugger module is installed for locally running php"

I see no module load errors in apache error logs. Any ideas, anyone?
View user's profileFind all posts by joe_ezSend private message
Veteran

Joined: 06 Jun 2007
Posts: 289
Location: Vancouver, Canada
Reply with quote
Your version 4.6.3 is a bit old. I do not know how well it works in Vista Confused

When I first started using PhpEd, I could not get the debugger to work until I specified the full path to the DBG module. The following setting currently works 100% for me (Windows XP, IIS, and PhpEd 5.0.1):
Code:
zend_extension_ts=C:\PHP\Ext\php_dbg.dll-5.2.x


Also worth considering, is running the DBG Wizard. It may just provide the clues you need! See http://www.nusphere.com/products/dbg_wizard_download.htm for more information.

Good luck Wink

_________________
Smile
View user's profileFind all posts by annoSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
try with external browser and check what it shows.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Similar Problem


Joined: 09 Nov 2007
Posts: 2
Location: Cincinnati
Reply with quote
I'm getting the same problem using version 4.6. I have XP with Apache 2.2.6 and PHP5.2.4. I installed the dbg tool and received the following error message: Failed to run DBG session

Reason: client ip address [(null)] lookup failed
Does anyone know where I need to set the client IP address to make this problem go away? thx.
View user's profileFind all posts by reneuendSend private messageMSN Messenger
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
Quote:
Does anyone know where I need to set the client IP address to make this problem go away? thx.

just run phpinfo() and check its output to see if _SERVER['REMOTE_ADDR'] is set. If not, you're in trouble and should address this issue to php and apache dev teams, see http://bugs.php.net and http://httpd.apache.org/bug_report.html
BTW, this problem did never happen under Apache 2.2.3 and earlier versions.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 13 Nov 2006
Posts: 6
Reply with quote
dmitri wrote:
Quote:
Does anyone know where I need to set the client IP address to make this problem go away? thx.

just run phpinfo() and check its output to see if _SERVER['REMOTE_ADDR'] is set. If not, you're in trouble and should address this issue to php and apache dev teams, see http://bugs.php.net and http://httpd.apache.org/bug_report.html
BTW, this problem did never happen under Apache 2.2.3 and earlier versions.


What other issues can cause this ? I have been using the debugger fine for some time now on apache 1.3.x, but I now need to develop against apache 2.2.x and am seeing this problem. So far, I have been using php 5.2.5 and have tried with apache versions 2.0, s.3 and 2.6 on both windows and linux (I need to test on both platforms) and I always get this error.

I have checked with phpinfo(); and it always shows the correct value for the _SERVER['REMOTE_ADDR'] variable, but for some reason, dbg.so cannot see that value.

Currently, the debug client is running on windows vista 32 bit with all the latest updates (though I think the problem is in the bdg module, not the client). If required, I can provide access to a system that exhibits this problem for you to debug. The linux server is running Centos 5 in a Xen virtual machine (if that matters) on a static real internet IP (ie. not NAT'd) and apache was installed / configured by cpanels easyapache.

Thanks for any pointers. I also have a copy of komodo that I used to use for development and when I try that using the xdebug module, everything works perfectly. But I really want to use the debugger built into phped as it is a much better debugger (when it works). Oh, and I'm using the latest version of phped and dbg.

Thanks for any pointers.

Martin

*EDIT*
Never mind, I found the problem. For some reason, firefox updated and screwed the settings in the toolbar. I had to set the clienthost setting correctly (which I don't think I've used in the past). That'll teach me to rely on the toolbar too much.
View user's profileFind all posts by macooperSend private message
[resolved] Failed to start debug, phped 4.6
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic