NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
v1.4, 64 bit support on linux


Joined: 30 Apr 2007
Posts: 1
Reply with quote
I downloaded the 1.4 version but have had problems using it on a SuSE 64 bit system. Installing the php extension produced the ELFCLASS32 error which from an earlier post in this forum I am lead to believe is due to a 32 bit .so on a 64 bit system. A response to that earlier post indicated that 64 bit support would be available in v1.4. Does this latest version support a 64 bit linux system?
View user's profileFind all posts by nhajekSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
x86_64 target platform is not supported at the moment but will be soon.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 24 Jul 2007
Posts: 5
Reply with quote
Any update on when a x86_64 linux version might be available?
View user's profileFind all posts by JaredSend private message
x86_64 support


Joined: 09 Jul 2006
Posts: 5
Reply with quote
same question here regarding 64bit support of phpexpress: I checked the site several times during the past months looking for 64bit support, read that it would be available as of v 1.4, actually bought the nucoder solution today (as hafi68) and discovered that it still only supports x86 as of August 10 2007
Any news on when the 64bit support will be available? My ZEND Guard license is expiring at the end of this month and it would be a shame to waist another USD 1200 on a 1 year license if nucoder support for 64 bit is around the corner (any rough estimates on code obfuscation availability?)
Thanks as always and keep up the great work you are doing!
hafi68
PS: I think getting that 64bit support out would be a prudent move in many ways as people running 64bit machines whose ZEND licenses are expiring and who might be thinking about switching their entire encryption scheme will otherwise have no choice except buying either both encoding, stick to ZEND and see what happens when with phpexpress or simply extemding their Guard license for another year forgetting about the alternative solution... (not so much because of the price because in comparison to the ZEND fees you offer an incredibly good deal, but setting up a bunch of 64bit servers takes time and once they are running and online hosting stuff then it becomes a real pain to reconfigure accelerators while trying to avoid configuration contingent downtime all too easily encurred when running a bunch of divergent accelerators...))
View user's profileFind all posts by phpquerySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
64bit libraries are still in the development phase. If you're interested in betatesting, please let me know by p.m.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 04 Oct 2007
Posts: 2
Reply with quote
We just purchased Nu-coder license and found out we needed PhpExpress to use it. We are running on RHEL 4 Linux 64bit
and can't get PhpExpress to work because it is not supported yet.

Do you have an updated release date for PhpExpress for 64 bit Linux?

Thanks.
View user's profileFind all posts by intendoSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Quote:
Do you have an updated release date for PhpExpress for 64 bit Linux?

Sorry, 64bit version is not available at the moment. There is still ongoing product development.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 04 Oct 2007
Posts: 2
Reply with quote
I understand that the 64 bit version of PhpExpress is not ready yet BUT those crazy people I work for keep asking me when I will be able to use the Nu-Coder software that they so graciously purchased for me to speed up and protect their application.

The question is WHEN do you estimate that the 64 bit version of PhpExpress will be released?

Thanks in advance.
View user's profileFind all posts by intendoSend private message


Joined: 24 Jul 2007
Posts: 5
Reply with quote
I too would like to know. This is extremely important to me, as NuCoder is completely useless to me until 64bit support is available.

I message for beta testing, but never got a response. Has anyone else got a respone for beta testing?
View user's profileFind all posts by JaredSend private message


Joined: 24 Jul 2007
Posts: 5
Reply with quote
Any update? Still have no use for NuCoder/PhpExpress as I'm still on 64bit/Linux
View user's profileFind all posts by JaredSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
If you're interested in beta-testing, please submit your request via "PM" on this forum and provide details about your h/w platform, OS and php version.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
v1.4, 64 bit support on linux
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic