NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Adding Zend_Extension in php.ini gives Apache a migraine


Joined: 03 Dec 2006
Posts: 26
Reply with quote
I am using the most recent release Tech Platform and am trying to install the IonCube Loaders. The line that IonCube says to add to the php.ini (in my case) is
zend_extension_ts="C:\Program Files\nusphere\TechPlat\apache\htdocs\ioncube\ioncube_loader_win_5.2.dll"

However, when I try to restart Apache, Apache croaks with this error:

Failed to start Apache
"C:\Program Files\nusphere\TechPlat\apache\bin\httpd.exe"
System Error: The system cannot find the file specified.


Looking at the System Event logs it shows:

Error
The Apache service named reported the following error:
>>> [Tue Oct 30 18:06:05 2007] [warn] module php5_module is already loaded, skipping .
The Apache2 service terminated with service-specific error 1 (0x1).


I am using Windows XPsp2
PHP 5.2.4
Apache 2.2.3
There are no other zend_extensions in php.ini
View user's profileFind all posts by RavenSend private messageVisit poster's website


Joined: 03 Dec 2006
Posts: 26
Reply with quote
More info. The php5 already loaded error is a result of the Apache httpd.conf. In the httpd.conf file around line 119 is LoadModule php5_module php/php5apache2_2.dll and then at the very end of the file are these lines:

BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
PHPIniDir "C:/Program Files/nusphere/TechPlat/apache/php/"
LoadModule php5_module "C:/Program Files/nusphere/TechPlat/apache/php/php5apache2_2.dll"
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL


I only used the Tech Platform installer so I have to assume that something went wrong there. However, by clearing up that error I now receive this error Faulting application httpd.exe, version 2.2.3.0, faulting module php_dbg.dll-5.2.x, version 0.0.0.0, fault address 0x00009dd3..

phped with the debugger on runs without any problem until I try to add the zend_extension line to php.ini.

HELP!
View user's profileFind all posts by RavenSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
As you noted, everything works without adding IC. So I'd recommend you to contact IC support in order to make it clear why their tool crashes apache.
Feel free to post their answer there.
TIA.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 03 Dec 2006
Posts: 26
Reply with quote
I have also contacted them and they pointed to: faulting module php_dbg.dll-5.2.x which is supplied by NuSphere.
View user's profileFind all posts by RavenSend private messageVisit poster's website


Joined: 03 Dec 2006
Posts: 26
Reply with quote
From IC support:

Quote:
Historically dbg has always crashed when the Loader is installed, and the Loader actually logged an error to say that dbg was incompatible so as to give the user a more helpful message. Given that components such as Zend Optimiser, EAccelerator, SourceGuardian all work fine with the Loader, this should tell you that the problem is with dbg though.

It may be the dbg is making assumptions that are simply no longer true when encoded files are used, and this causes a crash. Whatever the reasons though dbg really shouldn't fail, and it would be the job of the current dbg developers to resolve it.


I'm stuck in the middle here. From what I have read in the system error messages, it does appear that there could be a problem with the dbg module. I would appreciate your looking into this. Thanks.
View user's profileFind all posts by RavenSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
What a shame! Would they suggest or point out to any evidence that it's dbg has crashed?
I checked IC loader and it appears that it scans installed modules for dbg and if it's found, it unpacks "encrypted" error message and calls zend_error(). This alone causes the crash as it is unsafe to call zend_error at that point. If you install dbg after IC it won't be found and system will work. Lay this on them and ask why they are trying to fool you and bounced back to me Smile

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 03 Dec 2006
Posts: 26
Reply with quote
I have sent them another message.
View user's profileFind all posts by RavenSend private messageVisit poster's website


Joined: 03 Dec 2006
Posts: 26
Reply with quote
From IC:

As mentioned, the Loader checks for DBG and raises an error if detected because there have historically been crashes with DBG installed. We took the view that it was better to inform the end user that DBG was incompatible with a friendly message rather than there being a crash and the user left with no clue as to why. FWIW, Zend took a similar view and they do the same with their debugger by raising an error and reporting that the compiler handler is overridden if 3rd party components such as the Loader are installed. To our knowledge the Loader raising an error has never caused a crash before, and we have had customers mention the error message that they receive when they have tried to use DBG. You will find this in the following thread in our forum, and also some hints that may help you.

http://forum.ioncube.com/viewtopic.php?t=873&highlight=dbg

Whether or not what NuSphere say is correct is debatable given that the crash is within DBG rather than the Loader. DBG is not properly handling the situation of being asked to shutdown sounds more likely.

I will log this as something to look into, and we periodically reevaluate implementation decisions such as this in case they are no longer valid. In this case it may be that actually DBG no longer crashes with the Loader installed, and in that case we would definitely take out the check. We might also do this anyway as with DBG part of Nusphere, there may be an incentive to ensure compatibility that would have been lacking when DBG was merely a hobby project.
View user's profileFind all posts by RavenSend private messageVisit poster's website


Joined: 03 Dec 2006
Posts: 26
Reply with quote
Any further help? There is still no resolution and I, the customer, am left hanging. Sad
View user's profileFind all posts by RavenSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
What they replied is a kind of juggling facts. I think it's clear to you now that it's IC stops your server when it sees debugger. They did not leave you any choise. Why not to ask them what they supposed or intended to do?

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 03 Dec 2006
Posts: 26
Reply with quote
They have already replied "I've a follow-up on this having discussed the matter, and we've decided to remove the check in the next Loader revision. If there is still a crash with DBG then we can push the ball into NuSphere's court on that without question" and I have asked them to send to me, if possible, a patched version. I don't know if they will do that or not. I was just hoping that you might have a work-around.
View user's profileFind all posts by RavenSend private messageVisit poster's website


Joined: 03 Dec 2006
Posts: 26
Reply with quote
Dmitri,

Thank you for all your help with this!
View user's profileFind all posts by RavenSend private messageVisit poster's website
Adding Zend_Extension in php.ini gives Apache a migraine
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic