NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Just installed and hit a bug


Joined: 24 Jan 2008
Posts: 15
Reply with quote
A client reported a FATAL error after installing phpexpress.

The fact is that the poorly written scripts should generate a WARNING WITHOUT phpexpress:
Quote:

Warning: main(../data.php) [function.main]: failed to open stream: No such file or directory in /home/joedemo/domains/mso.hk/public_html/workorder/sys/top.php on line 3

Warning: main(../data.php) [function.main]: failed to open stream: No such file or directory in /home/joedemo/domains/mso.hk/public_html/workorder/sys/top.php on line 3

Warning: main() [function.include]: Failed opening '../data.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/joedemo/domains/mso.hk/public_html/workorder/sys/top.php on line 3

Warning: Cannot modify header information - headers already sent by (output started at /home/joedemo/domains/mso.hk/public_html/workorder/sys/order/emailcontrol.php:43) in /home/joedemo/domains/mso.hk/public_html/workorder/sys/top.php on line 8


but WITH phpexpress, a FATAL error is generated:
Quote:
Warning: main(../data.php) [function.main]: failed to open stream: No such file or directory in /home/xx/domains/abc.com/public_html/workorder/sys/top.php on line 3

Fatal error: Failed to load cached file (/home/xx/domains/abc.com/public_html/workorder/data.php) function unhtmlspecialchars is already declared in /home/xx/domains/abc.com/public_html/workorder/sys/top.php on line 3



Line 3 of /home/xx/domains/abc.com/public_html/workorder/top.php
Code:
include("../data.php");


while the script that is accesses via the browser is /home/xx/domains/abc.com/public_html/workorder/sys/order/test.php
Code:
<?

include("../../data.php");

// some other html + php

include("../top.php");

?>


not sure how the coder wrote these code...but I think showing FATAL error rather than WARNING is abnormal.
View user's profileFind all posts by hehachrisSend private message
Guru master

Joined: 05 Jul 2004
Posts: 660
Location: Belgium
Reply with quote
Are you sure the latest version of php express is installed on the server?
If I understand what you are writing correctly you might have the same problem as what i reported here.
View user's profileFind all posts by BlizzSend private messageVisit poster's website
Just installed and hit a bug
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic