NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[resolved] Remote debug starts when it shouldn't


Joined: 15 Feb 2007
Posts: 35
Reply with quote
When I open a url on my local server it always starts a debugging session, even without any query string at all and definitely not the usual ?DBGSESSID=0@clienthost:..

It even starts up PhpED if it's not open. Shouldn't this behaviour be limited to the use of ?DBGSESSID=0@clienthost:...?
View user's profileFind all posts by SpacemanSend private message


Joined: 15 Feb 2007
Posts: 35
Reply with quote
never mind.. a restart of Firefox fixed it

still a bit of a mystery how that sort of mapping could occur though
View user's profileFind all posts by SpacemanSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7893
Reply with quote
Debugger module running on the server issues cookie and it's what triggers debugger on the next turn when you navigate to a page. It's known as 'debugger session'.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 15 Feb 2007
Posts: 35
Reply with quote
cool.. I'll keep that in mind
View user's profileFind all posts by SpacemanSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7893
Reply with quote
you need to close instance of browser or issue dbgsessid with negative value and it will drop that cookie.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
[resolved] Remote debug starts when it shouldn't
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic