NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
wsdl syntax errors


Joined: 18 Dec 2003
Posts: 4
Reply with quote
Hello,
I'm trying to use the soap class via the NuSoap wizard of the PHPEd. There are certain wsdl syntaxes (for example Apache Soap 2.2) where i get XML error on line 1 : syntax error. What sort syntax is this ? Is there any plans to be supported in the future? Thanks.
View user's profileFind all posts by mpkSend private message
And something more


Joined: 18 Dec 2003
Posts: 4
Reply with quote
I can't get any wsdl to work over ssl...I know I must have curl and I do but...Any ideas?
View user's profileFind all posts by mpkSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Please submit your scripts and detailed instructions on how to replicate the problem to our http://www.nusphere.com/contact_us/.

Thanks,
Dmitri.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 18 Dec 2003
Posts: 4
Reply with quote
Ok forget the apache. The soapbuilders refers to a non existing wsdl (http://www.apache.org/~rubys/ApacheSoap.wsdl ) therefore the script responds with a syntax error (which is a bit misleading though).

I'm trying to parse this wsdl https://myserver/wsdl/vz33-vz34. I'm just using the default code produced by the wizard

require_once('nusoap.php');
$inputBoolean = "false";
$wsdl = "https://myserver/wsdl/vz33-vz34";
$soap = new soapclient($wsdl,"wsdl");

I'm getting this: Parser error: XML error on line 1: syntax error

Thanks and regards.
View user's profileFind all posts by mpkSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Hi.
There are two reasons for failure:

One, your URL does not work in form you supplied it
https://myserver/wsdl/vz33-vz34
while should be
https://myserver/wsdl/vz33-vz34/


Two, anyways NuSoap 0.6.x soapclient class does not work with HTTPS/SSL sites. You have to upgrade to NuSoap 0.7.0.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 18 Dec 2003
Posts: 4
Reply with quote
Hello,
Thanks for your prompt replies.
1. I have tried it also with the slash, so that's for sure not the problem
2. I cannot find any reference in this world to the 0.7.0 version of the class. Is it anywhere hidden?
View user's profileFind all posts by mpkSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Quote:
1. I have tried it also with the slash, so that's for sure not the
problem

It's surely a problem, because without slash, you site responds with HTTP/404.

Quote:
2. I cannot find any reference in this world to the 0.7.0 version of the class. Is it anywhere hidden?

It's in beta-stage testing. If you're insterested in testing it, please let me know at http://www.nusphere.com/contact_us/.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
wsdl syntax errors
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic