NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[resolved] Can I use the phpexpress with the debugger?


Joined: 08 Mar 2006
Posts: 10
Reply with quote
Hi,
Is the debugger (PhpEd latest) compatible with phpexpress?
If I recall, I couldn't use the debugger when I had eaccelerator running.

Thanks!
Joe K.
View user's profileFind all posts by JoeKSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7893
Reply with quote
Sure. PhpExpress 1.3.14 and all versions that will be released after this are compatible with NuSphere Php Debugger.
We had some problems in earlier versions, but they are completely fixed in this version.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 08 Mar 2006
Posts: 10
Reply with quote
Dmitri,
Thank you. However I've been unable to debug while PhpExpress is loaded. I downloaded the latest version (linux) and the file date is Jan 2. Is this the right version?

Thanks,
Joe
View user's profileFind all posts by JoeKSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7893
Reply with quote
Thanks for pointing out to this problem. Indeed, there were old binaries on the web. We replaced them a hour ago. FYI: phpexpress that shipped with nu-coder was good all the time.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 08 Mar 2006
Posts: 10
Reply with quote
Hi Dmitri,

I downloaded the software for Linux again, and now it's dated January 29, version 1.3.11 (using phpexpress())
Still doesn't work with the debugger...

Thanks for helping.
Joe
View user's profileFind all posts by JoeKSend private message
My mistake...


Joined: 08 Mar 2006
Posts: 10
Reply with quote
Sorry... My mistake...
I had put the .so in the wrong directory( /usr/lib/php/modules, instead of /usr/lib/php5/modules). I had the old version in php5/modules so that's why it didn't see the new one. All set now - I can debug! (1.3.14)

Thanks again!

Joe K.
View user's profileFind all posts by JoeKSend private message
[resolved] Can I use the phpexpress with the debugger?
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic