NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
problems using the prof_results.php


Joined: 01 Dec 2003
Posts: 3
Reply with quote
ok. i got this is in my php.ini

[debugger]
debugger.enabled = true
debugger.profiler_enabled = true
debugger.JIT_enabled = 1
debugger.JIT_host = clienthost
debugger.JIT_port = 7869

phpinfo() shows that the extension loads fine. i set auto_append_file to the prof_results.php file. the file is appended like it should be but all i get is the header of the table. nothing is returned from the debugger. i'm confused.

i'm running php 4.3.2 and the latest release of dbg on RH linux 9. can someone help me out here?!
View user's profileFind all posts by hagiosSend private message


Joined: 04 Dec 2003
Posts: 2
Reply with quote
I too am having the same issue.

My php.ini:

extension=dbg.so

[Zend]
zend_optimizer.optimization_level=15
zend_extension=/usr/local/Zend/lib/ZendOptimizer.so
zend_extension=/usr/lib/php/dbg.so

[Debugger]
debugger.enabled=On
debugger.profiler_enabled=On
debugger.JIT_host = clienthost
debugger.JIT_port = 7869
debugger.fail_silently=Off
debugger.JIT_enabled=On

The array $dbg_prof_results is being returned as :
Array ( [mod_no] => Array ( ) [line_no] => Array ( ) [hit_count] => Array ( ) [tm_max] => Array ( ) [tm_min] => Array ( ) [tm_sum] => Array ( ) )

PHP 4.2.3
View user's profileFind all posts by xnuiemSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
DBG 2.11.x profiler captures performance data only during debug session.
Hopefully it will be improved in a next version.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 04 Dec 2003
Posts: 2
Reply with quote
Couldnt get 2.11.23 to do it.

However I had forgotten i had 2.11.5 in production and working there.

In php.ini I have
extension=dbg.so

[Zend]
zend_optimizer.optimization_level=15
zend_extension=/usr/local/Zend/lib/ZendOptimizer.so
zend_extension=/usr/lib/php/dbg.so

[Debugger]
debugger.enabled=on
debugger.profiler_enabled=on

I am running PHP 4.2.3-8 (yes its an RPM) on Red Hat 9 with Apache 1.3.28

Hope this helps.
View user's profileFind all posts by xnuiemSend private message
using it?


Joined: 01 Dec 2003
Posts: 3
Reply with quote
ddmitrie wrote:
DBG 2.11.x profiler captures performance data only during debug session.
Hopefully it will be improved in a next version.


so how exactly do you use the prof_results script. i'm sorry for being a bit of a n00b on php debugging.
View user's profileFind all posts by hagiosSend private message
problems using the prof_results.php
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic