NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Just bought it and got a problem, never hits breakpoints.


Joined: 03 Jun 2006
Posts: 1
Reply with quote
I bought PHPed today, and followed all the instructions about setting up the remote debugging. I am using an xampp setup for the 3rd party webserver and mysql server , it is running on my local machine.
php ver 4.3.10 used the correct dll
setup a project correctly I think.

When I open a file to be debugged in the workspace, I then hit F9 and it opens the web browser I hit F9 again and the script runs to the end. I have set 5 breakpoints yet it never hits them (at least the hit counter shows 0) If I F7 thru the code it follows the logic as it should and goes thru the breakpoints. (so I know it should hit them when running). The scripts only stop, because "Stop on the first line after run" is checked, but I can't get it to stop on any breakpoint I've set.

Any Ideas as to what I may be missing.

Thanks

TI
View user's profileFind all posts by the_idolSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
Dear Peter,

Please follow these instructions and make sure you have correct project settings:
http://forum.nusphere.com/howto-debug-remote-website-with-phped-t1860.html

In particular, once your server is running locally, Project root directory should be pointing to the Apache DocumentRoot directory, it's where all the web tree begins. Remote root directory should be the same as Project root.

Then make sure that you commented off php opcode cache that comes with XAMPP.
Don't forget to restart Apache after any changes you do to php.ini and check that phpinfo() reflects them.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Just bought it and got a problem, never hits breakpoints.
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic