NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
File is marked as changed whithout any changes. *solved*
Veteran

Joined: 22 Sep 2005
Posts: 113
Reply with quote
PhpED is marking the file as changed (with that "*" near the name in the file tab) even if I make no changes in file.

As an example, after saving all open files in a debug workspace, when I get into one file openned by the debugger in a step-into(F7) mode, the file openned is marked as changed. When I close it, phped asks me if I want to save it.

This also occur sometimes when I just select text in the file.

This is annoying, because I loose control of files altered when I compare directoies from my local machine and the remote server.


Last edited by HoTShoT on Wed Jan 25, 2006 4:06 pm; edited 2 times in total
View user's profileFind all posts by HoTShoTSend private message
Veteran

Joined: 24 Jan 2006
Posts: 311
Reply with quote
Dear HotShot, could you please supply more details - I checked it on my 4.0.1 build 4051 and couldn't reproduce it at all. Are there any particluar steps or actions that you are taking?
Here is what I did:
Loaded two scripts, one calls another via include.
Changed both of them
Saved both of them
Started debugging the first one (local debugging)
Steped into the second one - it still opens up as saved file.

is that the scenario you were talking about?
View user's profileFind all posts by yfaktorSend private message
Veteran

Joined: 22 Sep 2005
Posts: 113
Reply with quote
yfaktor wrote:
...is that the scenario you were talking about?

Yes, it is. This happens when you uncheck the "Make editor readonly while debug session" in Tools>Settings>Tools>Debugger.
View user's profileFind all posts by HoTShoTSend private message
Veteran

Joined: 24 Jan 2006
Posts: 311
Reply with quote
H-m. Mine is unchecked and i did try changing the files while debugging and saving it. Let me play some more with that - are there any other tricks to get this to show up? Maybe ddmitrie knows something about it. BTW, whcih build of PhpED are you using?
View user's profileFind all posts by yfaktorSend private message
Veteran

Joined: 22 Sep 2005
Posts: 113
Reply with quote
Build 4048
View user's profileFind all posts by HoTShoTSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Actually it all was discussed there many times Smile

opening-a-file-wants-me-to-save-t717.html
editor-changed-flag-and-undo-operations-t896.html
marking-as-modified-t1660.html

In short, when Optimal Fill checkbox is checked, editor _modifies_ the file for you to get all indented spaces optimally filled with tabs (if enabled with Use Tab character) or not. Additioanlly, when "Keep trailing blanks" is not checked, editor does also _modify_ the file for you when removes these trailing blanks Smile
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 22 Sep 2005
Posts: 113
Reply with quote
Yes, my "optimall fill" was enabled. Solved now Smile

I didn't find those posts the way I searched. Since it's a so common complaint and is so simple to solve, may be it should be in the FAQs.
View user's profileFind all posts by HoTShoTSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
sure Smile
post7021.html
View user's profileFind all posts by dmitriSend private messageVisit poster's website
File is marked as changed whithout any changes. *solved*
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic