NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Segfaults using DBG


Joined: 28 Sep 2003
Posts: 3
Reply with quote
Hi,

I have a problem with PHPEd & DBG. My debug session just terminates every now and then, when this happens I get a 'disconnected' message in the DBG listener log and 2 segfault messages in my Apache2 error_log. I can't really reproduce it, but it makes debugging a real pain in the *ss.

I'm using :

Gentoo linux
Apache 2.0.47
PHP 4.3.2
DBG 2.14.10, dbg-4.3.2.so (tried i386 and i686 versions)

Any clues ? Thanks.
View user's profileFind all posts by FredSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
php support for Apache 2 is experimental and please do not expect it to work stable Smile. I think DBG is not involved.
Also, don't forget to make sure you have no ZendOptimizer nor ZendAccelerator nor ZendExtensionManager loaded. These software products make some troubles if any 3rd party debugger extension is loaded.

Please let me know if you get any problem with Apache 1.3.27 or higher.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 28 Sep 2003
Posts: 3
Reply with quote
ddmitrie wrote:
php support for Apache 2 is experimental and please do not expect it to work stable Smile. I think DBG is not involved.
Also, don't forget to make sure you have no ZendOptimizer nor ZendAccelerator nor ZendExtensionManager loaded. These software products make some troubles if any 3rd party debugger extension is loaded.

Please let me know if you get any problem with Apache 1.3.27 or higher.


Hmm that's a bit of a problem, I'm using Gentoo Linux and apache2 is the default. Otherwise, PHP runs fine for me with apache2.
I'm not using the Zend optimizer or accelerator.
I'll try to find a way of installing Apache 1 on my box and see if that helps.
View user's profileFind all posts by FredSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
Just to verify if the proble is with dbg.so-4.3.2, could you try out dbg.so-4.3.1 or 4.3.3 ? They are all compatible.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Segfaults using DBG
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic