NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Zend Optimizer and Debugging Problem


Joined: 17 Oct 2003
Posts: 3
Reply with quote
I am evaluating phpED. The editor works great, but I have an issue with debugging. I'm running locally on a Windows XP computer using IIS and MySql. I had PHP v4.1.2 installed prior to installation of phpED, which I have to support an application while I develop a new version. Due to some XML/XSLT issues, it won't run currently in 4.3.3.
I use a 3rd party library which is encoded and requires me to use the ZendOptimizer.

* If my debug session is setup to use PHP 4.3.3, which phpED installed, it doesn't load the Optimizer so I can't debug past the load of the library files. If I manually add the [Zend] section to the php.ini file, it still doesn't work. I uninstalled/reinstalled ZendOptimizer and it only sees my original php.ini file, not the new one.

* If I point my debugger to use my existing PHP 4.1.2 installation and php.ini file, I get the following error:

Code:
Failed to start debug session (timeout)
Please verify settings for the local debugger module.

If I can figure out the debugging issue, I plan to purchase phpED. Anyone have any suggestions?
View user's profileFind all posts by winninghamwSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
If you run encoded files, you won't be able to debug them anyway, just because you don't have sources. Regarding the rest stuff, I think threre should not be any problems. Try to comment out extension=dbg.so-4.1.2 and add zend_extension=dbg.so-4.1.2 or zend_extension_ts=php_dbg.dll-4.1.2 if you run your server under windows. Then open phpinfo results and make sure that everything dbg is listed there.
If you got any further problems please read PHPED 3.2 FAQ and if you still can't resolve the problem please contact me by email support AT nusphere DOT com.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 17 Oct 2003
Posts: 3
Reply with quote
I'll try what you suggest. The only files I have that are encoded are the ones in the 3rd party library I have. I shouldn't need to debug those, but I don't have un-encoded source for them.
View user's profileFind all posts by winninghamwSend private message


Joined: 17 Oct 2003
Posts: 3
Reply with quote
I just installed a copy of PHPEdit v0.8.0.25 to check it out. I installed DBG and I was able to get it to work fine with ZendOptimizer. It broke my install of phpED though. PHPEdit installed version 2.11 of DBG where phpED has version 2.14.

I uninstalled both apps and reinstalled phpED and I still get the same (timeout) issue.

I'd still prefer to get phpED to work. Any ideas?
View user's profileFind all posts by winninghamwSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Send me phpinfo results and php.ini file.
I think, the problem is with server part.
Also, please send me screenshots of phped settings on IDE tab and project settings.

TIA.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
According to php.ini you have the following lines related to ZO:
Code:
[Zend]
zend_optimizer.optimization_level=15
zend_extension_ts="C:\Program Files\Zend\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts="C:\Program Files\Zend\lib\Optimizer-2.1.0"


Correct them to
Code:
[Zend]
zend_optimizer.optimization_level=15
zend_extension_ts="C:\Program Files\Zend\lib\Optimizer-2.1.0\php-4.3.x\ZendOptimizer.dll"


and php_dbg.dll-4.3.3 should be loaded using
extension=php_dbg.dll-4.3.3
not zend_extension_ts=...
as I suggested before.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Zend Optimizer and Debugging Problem
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic