NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
PhpEd 4.0 Problem


Joined: 01 Sep 2005
Posts: 3
Reply with quote
I've installed evaluation copy of PhpEd 4.0 Build 4033 and it has several problems that makes it practically unusable:

1) All source codes have spanish comments and text which contains letters with apostrophes. All these get corrupted when opening a new document
2) When saving edited document, it says "Failed to translate file encoding UTF-16LE to Windows-1251", thus changes all special characters to "?".
3) Changed "Settings - Default file encoding" to UTF-16LE: No effect
4) All source files use ANSI encoding
5) At first, I couldn't even type special characters correctly, had to change in Appearance to use ANSI charset. This is because I type in spanish but have russian fonts enabled in Windows so I can read text in russian.

Is there a fix for this or do I have to uninstall and use something else?

P.S. There seem to be no evaluation download for previous version...

Edit: Another bug... when opening files accidently clicked on "System Volume Information" and the program got closed Rolling Eyes
Edit 2: Another problem. Opening HTML document in the same ANSI encoding... and it gets opened as series of squared [] blocks. Shocked Uninstalling...
View user's profileFind all posts by lifepowerSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
Quote:
All source codes have spanish comments and text which contains letters with apostrophes. All these get corrupted when opening a new document

You may want to set default file encoding to Windows 1252 (Western EU) or whatsoever you really use (see tools->settings->IDE). Alternatively, you may want to select encoding when you open files via File->Open menu.

Quote:
When saving edited document, it says "Failed to translate file encoding UTF-16LE to Windows-1251", thus changes all special characters to "?".

It explains previous problem too. You have Russian codepage set for your Windows while trying to edit non-russian files. See previous answer.

Quote:
Changed "Settings - Default file encoding" to UTF-16LE: No effect

It makes no sense until you want to edit UTF-16 Little Endian files. You probably are not going to do so Smile

Quote:
All source files use ANSI encoding

ANSI standard defines approx. few hundred if not thousands encodings. Which one do you have?

Quote:
Another problem. Opening HTML document in the same ANSI encoding... and it gets opened as series of squared [] blocks

It is because you have set UTF16LE while your files are not UTF16.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 01 Sep 2005
Posts: 3
Reply with quote
ddmitrie wrote:
You may want to set default file encoding to Windows 1252 (Western EU) or whatsoever you really use (see tools->settings->IDE). Alternatively, you may want to select encoding when you open files via File->Open menu.

Tried various encodings without success.

ddmitrie wrote:

It explains previous problem too. You have Russian codepage set for your Windows while trying to edit non-russian files. See previous answer.

Changed codepage and since previous answer didn't help - no effect Sad

ddmitrie wrote:
ANSI standard defines approx. few hundred if not thousands encodings. Which one do you have?

Not sure Shocked but I use multiple programs (notepad, dreamweaver) and none had problems opening these files and never had to edit encoding and other options in them. Furthermore, I sent the file to a friend of mine and he opened it with PhpEd 3.x - no problems (he uses same language options). PhpEd 4.0 is the first to have problems with it Confused
View user's profileFind all posts by lifepowerSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
It's b'ze most of the editors are not unicode and do not care of the encodings. So they are not good samples, really. With them you won't be able to edit russian text and spain text simulteneously.
With unicode editors you either edit unicode files (UTF8 or UTF16 etc) and it's just fine, or you have to specify the encoding.
If for example you open a KOI-8 mail in your mailer, does it always set proper encoding for you?
In most cases it does, b'ze it knows where each mail has appropriate header with encoding.
But not always.
As of PHPED v4, it has general-purpose editor which knows nothing of what you're going to edit. HTML, php, js, css, xml etc etc etc.
In most cases you'll work with just one encoding. Set it in the settings and it will work fine.
If not, contact NuSphere support by email and the problem will be resolved pretty fast.
Not a big deal Smile

Quote:
Tried various encodings without success

Check again with Windows-1252.
File->Open, select Windows 1252 encoding in the right bottom corner.
Finally check if this table http://www.microsoft.com/globaldev/reference/sbcs/1252.mspx contains correct symbols for your file.
Another code page people are using in West EU countries is ISO 8859-1. You may want to check it too...
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 01 Sep 2005
Posts: 3
Reply with quote
Ok, thanks a lot, ddmitrie! Smile
View user's profileFind all posts by lifepowerSend private message
PhpEd 4.0 Problem
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic