NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Help: PHP can't use OpenSSL


Joined: 20 Jun 2014
Posts: 4
Reply with quote
Hi,

I'm running PhpEd under Windows 10. When I run my code from PhpEd's debugger, and my code uses HTTP_Request2 to open a session with an https URL, I get the error: Script Socket.php raised exception class HTTP_Request_LogicException with message "Need OpenSSL support for https:// requests at Socket.php, line 234".

I ran phpinfo(), found my php.ini file and confirmed that the line 'extension=php_openssl.dll' is not commented out. phpinfo reports 'SSL Version OpenSSL/1.0.2j'.

But phpinfo also says 'OpenSSL support: disabled (install ext/openssl)'.

So I went to my extensions directory (phpinfo said 'extension_dir: C:\Program Files\NuSphere\PhpED\php56\extensions') and confirmed that php_openssl.dll is in that directory.

So it seems to me that the extension is specified correctly and the extension dll is available. So what could be the problem?

Thank you,
Bob
View user's profileFind all posts by altairSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
1 - debugger has no relation to ssl or plain/text communication between php script and your web
2 - error means you need both -- SSL on your client _and_ SSL on your server. Looks like either your server does not support SSL or your client was rejected for some reason
anyway, supporting PHP scripts is out of this forum scope. Please try php.general newsgroup

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Help: PHP can't use OpenSSL
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic