NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Smart Sync keeps reporting same files as out of sync


Joined: 23 Jan 2015
Posts: 16
Reply with quote
Is anyone else having this issue with Smart Sync? I've tried changing the setting in Misc to use Dates only, File size only, and Both, but smart sync keeps reporting the same files as being out of sync, even after I let smart sync Run and update the copy on server.

However, if I flag each file to "remove from server" and then click Run, it removes the file, and then smart sync is works fine the next time I run it. -- But as soon as I make a change to a php file, and run smart sync again, and have it Update the copy on server, and then run smart sync again, it still sees the file as being out of sync (either dates don't match or file size doesn't match depending which setting I try).

So it seems that smart sync works when a file is "missing" from the server, and it uploads the missing file. But when it detects files are different, and it updates, it doesn't seem to be updating or is not able to compare the date or file size or is reading a cached server folder list, or something.

Maybe I'm missing something I should be doing? Any help would be appreciated. This is a critical feature that I need for a laravel project. Thanks.
View user's profileFind all posts by markh1Send private message
Smart sync solved. Uncheck "use cache" option in A


Joined: 23 Jan 2015
Posts: 16
Reply with quote
I just answered my own question. By unchecking the "Use Cache" option in the phped Ftp Account settings, it reports correctly, after updating to the server, and running smart sync again.

However, with the "use cache" option unchecked, the smart sync is about 10 times slower. Seems overly slow. Not sure why so slow. I'm excluding the heavy folders, and it's only scanning 116 files. And my internet is pretty fast.

But the question I have now, is what good is the "use cache" option, if the cache doesn't get updated when a file is uploaded to the remote server? Having the use cache option checked, causes smart sync to continue comparing against an old (cached) directory listing from the server, even after smart sync updates are run.

I wonder if this is by design, or is it a bug?
View user's profileFind all posts by markh1Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
I didn't experience any problems with cache. If you send me all details and provide with an access to your server, I'll give it a try.
I don't think we can fix it without reproducing.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Followup. Smart Sync is working fine


Joined: 23 Jan 2015
Posts: 16
Reply with quote
Just to follow up. I've now had the "Use cache" option in ftp account settings, checked for well over a month, and smart sync has been working perfectly. I'm thinking that maybe the problem I had originally, was fixed by unchecking "Use cache", and running the sync. Thanks Dmitri for a great product!

If anyone is using Laravel 5.x, here are the Publishing filter settings that work well for me, in case you're interested:

Don't publish directories = CVS;.svn;.git;vendor;public;/;storage;bootstrap
Allow files = empty
Disallow files = *.env;composer.*

Top publishing directory = /myapptopfolder
View user's profileFind all posts by markh1Send private message
Smart Sync keeps reporting same files as out of sync
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic