NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Incompatible version of debugger module is detected-Solution


Joined: 23 Jan 2015
Posts: 16
Reply with quote
I'm posting this to help anyone else who may need help on how to update the phped DBG debugger version in php on wamp. I spent hours and hours trying to make sense of the phped docs. Not being all that familiar with wamp and php extensions, it was difficult to understand the short docs on this in the phped docs. So hopefully this will help someone else.

Here was my initial problem:
i updated phped from v:16 to v:17.
After that, i could not debug, and phped was displaying the message: Incompatible version (7.6) of debugger module is detected.

Here's what to do:

Download the debugger wizard php script from: http://www.nusphere.com/products/dbg_wizard_download.htm
And save the script in your c:\wamp\www\ folder.
Then in your browser go to: localhost/dbg-wizard.php
All this "wizard" does is tell you the info you need (below), in order to determine which dbg-php-x.x.dll files you need to copy from the folder tree: C:\Program Files (x86)\NuSphere\PhpED\debugger\server\Windows
The Bolded lines below are significant:

Here's what the wizard displays for me:

Quote:
I see that:
PHP Version: 5.5.12
•Web Server: Apache/2.4.9 (Win64) OpenSSL/1.0.1g PHP/5.5.12
•Server Name: localhost
Platform: WINNT/x86_64_VC11
•Your Client IP Address: ::1
•Your Server IP Address: ::1
•Port: 80
•Your Web Server is on the same machine with PhpED
•Path to website files: c:\wamp\www\
•Document Root is: c:\wamp\www\
•Your PHP.INI file is: C:\wamp\bin\apache\apache2.4.9\bin\php.ini
PHP extensions directory is: c:\wamp\bin\php\php5.5.12\ext\
•DBG (PHP DEBUGGER) Version 7.6.8 is INSTALLED

1. Installed DBG module is of an older version than currently available from NuSphere


The info generated by the wizard above tells us what to copy. (Note: it's not a wizard in the sense that it sets things up for you. But it gives you the info you need in a concise short list).

The bolded lines above, tell me: that i need to manually copy the file from: C:\Program Files (x86)\NuSphere\PhpED\debugger\server\Windows\x86_64_VC11\dbg-php-5.5.dll

Into wamp's php extensions folder: c:\wamp\bin\php\php5.5.12\ext\

Then restart wamp, and walla! debug is now working again!
Very Happy


Last edited by markh1 on Sun Sep 18, 2016 12:58 am; edited 6 times in total
View user's profileFind all posts by markh1Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
debugger module is just a dll and it's what you need to update in php configuration running on your wamp. Details are platform configuration specific. Project settings wizard leans them and shows clear instructions -- you have to follow them, shouldn't be a big deal.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
It's not that good to post something, then replace it with completely different.
Well, that's not project settings wizard. That's debugger wizard script that is used by the project settings wizard. Latter is what you actually needed from the beginning.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 23 Jan 2015
Posts: 16
Reply with quote
Thanks. yes, i figured out what i needed, and changed my post from asking for help, to providing help in case someone was confused as i was, and not as familiar with php and how to update the phped debugger version while using wamp. i hope it helps someone else. i didn't see your 1st reply until after i posted my change, which is why i thought it was ok to change it. thanks for following up.
View user's profileFind all posts by markh1Send private message
Incompatible version of debugger module is detected-Solution
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic