NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
PHPUnit


Joined: 20 Aug 2016
Posts: 1
Reply with quote
I am trying to turn on PHPUnit. I followed the instructions that Google found in this forum (even though they are years old) and I get this:

C:\Users\spence>"C:\Program Files (x86)\NuSphere\PhpED\php5\php.exe" "C:\Users\spence\AppData\Roaming\NuSphere\PhpED\unitTest\phpunit-4.3.3.phar" "C:\MedicareConsul\MCSsrc\TestSuite\DateRangeTest.php"

Parse error: syntax error, unexpected T_FUNCTION, expecting ')' in C:\Users\spence\AppData\Roaming\NuSphere\PhpED\unitTest\phpunit-4.3.3.phar on line 16

C:\Users\spence>

I have a test which tests a newly authored class. I can step through the test with the debugger but the output apparently goes somewhere I can't see.

Also, I have put the test in a testsuite directory, but when I hit F6 PHPEd can't find it. Is there some naming convention of which I am unaware?

Thanks,
Michael D. Spence
Mockingbird Data Systems, Inc.
View user's profileFind all posts by mspencenySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7894
Reply with quote
php5\php.exe
^^^^

you need php53\php.exe

and check that php.exe installed in this directory is 5.3.3 or higher

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
PHPUnit
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic