NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Upgrade reminder not stopping.


Joined: 18 Jul 2007
Posts: 30
Location: Pittsburgh, PA
Reply with quote
I've been a user of NuSphere PhpED for a good 8 years. Ever since v16 was released, my install of v15 reminds me to purchase an upgrade every time I start the software.

I don't appreciate this. There's an option to not be reminded again, but it appears to do nothing.

Is there any way to stop NuSphere PhpED from being nag-ware?

_________________
Ya
View user's profileFind all posts by loki_racerSend private message


Joined: 16 Jun 2011
Posts: 31
Reply with quote
Same thing here, this option doesn't work anymore since v16 came out.
I also use v15 currently.
View user's profileFind all posts by brainSend private message


Joined: 16 Jun 2011
Posts: 31
Reply with quote
probc2 wrote:
Why not just pay for an upgrade and support the developers livelihood? Chances are it'll stop nagging.


We are in our company already have the team4 license since years, also with v16, but for some internal reason we use v15.
So please don't come with such a comment, i guess the topic poster and me are long time nusphere users with valid licenses.
View user's profileFind all posts by brainSend private message
Guru master

Joined: 24 Jul 2009
Posts: 732
Reply with quote
What happens if you go into Tools > Settings > IDE > IDE Settings then untick the option for Check for new version ?

There was a bug with v14 where that didn't work but I thought that was fixed in v15.
View user's profileFind all posts by plugnplaySend private message


Joined: 10 Sep 2007
Posts: 18
Reply with quote
probc2 wrote:
Why not just pay for an upgrade and support the developers livelihood? Chances are it'll stop nagging.


Umm yeah. I'll pay for an upgrade when the new version has something I need/want. When you buy a product you are not then obligated to support the makers of that product for the rest of their lives.

If this reminder box came up when i first started the program it would be a minor annoyance that I would just live with. Unfortunately it comes out of nowhere at some random point in the next half an hour when you are typing away and the focus is stolen to ask you to upgrade. And this happens EVERY single day and no setting switch stops it. Sorry but it is starting to really piss me off and I'm seriously thinking of switching to something else just on principle. I do not use frameworks which is pretty much all the newer versions seem to be about and I'm not paying good money for nothing of use to me.

In fact now I'm thinking about it if the coming version has nothing but new framework support added I'm going to look for a new program. This does not mean phped is a bad program, far from it, however after three versions adding nothing of use to me I might be better off looking elsewhere.

I should also add that of all my colleagues who use to use this program I am the only one still doing so. They have all moved on for the exact same reason. I'm the last one still being loyal to it.
View user's profileFind all posts by ricktuSend private message
Guru master

Joined: 24 Jul 2009
Posts: 732
Reply with quote
It's NuSphere DBG which keeps me using PhpED. I also use regularly use xdebug and I find that it causes problems. I think some of its inspections can actively changing how the code runs. DBG doesn't have those problems.
View user's profileFind all posts by plugnplaySend private message


Joined: 10 Sep 2007
Posts: 18
Reply with quote
probc2 wrote:
I could just imagine what their support department is replying back to you with as well "send screenshots", and "we cant reproduce the problem". I've been down that path a number of times with them on various bugs with virtually no resolution.


Actually they did respond when I contacted them about it. They said they knew about the bug and it has been fixed in the latest version but they would not fix it in my version (14) because work on it has been closed off.

While I can appreciate that pretty much all development companies close off development work at some point for past versions they have an awful lot of their customers still working on versions 14 and 15 however this is a major bug that is causing them to lose goodwill with their customers so not fixing it is a bad business decision. Especially when it must be a very minor fix. Comment out the line of code that opens the reminder if they wanted to be quick about it.
View user's profileFind all posts by ricktuSend private message
Guru master

Joined: 24 Jul 2009
Posts: 732
Reply with quote
I wonder how long this post will be here before it gets deleted Wink

For a lot of editing I do now use PhpStorm because the IDE is just so much more helpful and I've been having bad performance issues with PhpED where it regularly hangs with high CPU and memory.

For 'convenience' I do sometimes use Xdebug, but I often regret that and revert back to PhpED for debugging. Then when I am done with debugging, I get frustrated with the PhpED issues and go back to PhpStorm for coding.

It appears Xdebug and Yii just do not get along. Something about Xdebug causes Yii to throw errors all the time whilst single stepping, as if Xdebug is inspecting objects and/or properties in advance and causing them to be initialised too soon.

Well, I'm unsure if it is Xdebug or something PhpStorm does, but debugging the same code in PhpED is never a problem.
View user's profileFind all posts by plugnplaySend private message


Joined: 18 Jul 2007
Posts: 30
Location: Pittsburgh, PA
Reply with quote
probc2 wrote:
Why not just pay for an upgrade and support the developers livelihood? Chances are it'll stop nagging.


I guess you missed the part where I said I've been using/paying for the software for 8 years.

_________________
Ya
View user's profileFind all posts by loki_racerSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7917
Reply with quote
We've done with v16 and ready to start deplying v17. Sorry, at this point we cannot make any changes and release any updates to v15.
There are only two options: 1) check "remind me later" - it will postpone next reminder by 2 weeks 2) purchase update with good discount.

loki_racer wrote:


I guess you missed the part where I said I've been using/paying for the software for 8 years.

I guess you missed the point -- EVEN if we released update to v15, you'd not get this update without active subscription. You need to renew subscription anyway.
If you renew, you'll get v16 where this problem has already been fixed.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 18 Jul 2007
Posts: 30
Location: Pittsburgh, PA
Reply with quote
dmitri wrote:
1) check "remind me later" - it will postpone next reminder by 2 weeks


That functionality doesn't work. It's broken. Hence my post here. No matter what I, or others, do, the software nags me once a day.

dmitri wrote:
2) purchase update with good discount.


v16 added nothing of value for me as far as I could determine. If it had fixed a number of bugs in the software, then I would consider an upgrade.

It's a pretty crappy business policy to ask people to upgrade, once a day, on software that they have already paid for. It's an even worse business policy to refuse to remove the nag modal from paid software. You can look at my account history, I've been a customer for almost a decade. Your response to this thread will make me seriously reconsider if I want to continue to be a supporting user of this software.

_________________
Ya
View user's profileFind all posts by loki_racerSend private message
Guru master

Joined: 24 Jul 2009
Posts: 732
Reply with quote
loki_racer wrote:
It's a pretty crappy business policy to ask people to upgrade, once a day, on software that they have already paid for. It's an even worse business policy to refuse to remove the nag modal from paid software.


It's clearly not a business policy; it was a BUG. It wasn't intended to be a nag modal.

I understand it is annoying you, but you can't expect them to retrospectively fix a bug in v15 when v16 shipped nearly 8 months ago. You can be reasonably sure that no other software company would; they would almost certainly ask you to pay for an upgrade.
View user's profileFind all posts by plugnplaySend private message
Upgrade reminder not stopping.
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 2  

  
  
 Reply to topic