NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Using with phpBB


Joined: 08 Aug 2016
Posts: 2
Reply with quote
Just installed the trial version of PhpEd, windows 64 bit, wamp server. Default browser is Firefox. I created a new project, settings to local server, right clicked on the "forums" root and activated it.

With phpBB 3.1x, the "extensions" are now being used instead of the old mod style of things. And this is where my issue comes into play. Smile

I have an extension I created that will do some extra data insertion when a new user signs up. It works perfectly. Some of my other extensions don't. So in order to become familiar with this IDE, I set some break points on the extension function "main_listener.php" which I know works, just to see how this interface works...

With "forums" highlighted, I hit the run button... the forums loaded in my firefox browser. I registered a new account, and it worked. However none of the break points were hit.

Is there something special I need to do with this? Do I need to use some form of internal firefox browser within ED instead of my full version?

Needless to say, I am pleased to see you folks using phpBB, which saves me a whole lot of additional explaining.

Thanks kindly in advance.

Gary
View user's profileFind all posts by dbsDevSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7878
Reply with quote
Check this first http://www.nusphere.com/kb/technicalfaq/php_breakpoints.htm

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Guru master

Joined: 24 Jul 2009
Posts: 716
Reply with quote
If you want to check if the basic debugger communications are working, you can try putting a DebugBreak() into your code. Even if breakpoints for some reason are not being sent to the debugger, if the DebugBreak() works that that confirms part of it is working.

You don't need to use the embedded PhpED browsers. Many people do, personally I never do and always use full external browsers. PhpED allows you to use external browsers just fine.
View user's profileFind all posts by plugnplaySend private message


Joined: 08 Aug 2016
Posts: 2
Reply with quote
Thanks, I think I got the basic debugger working using the "run debug" command.. (not sure how to get things working with an external browser but that is kind of moot at this point)

I tried many things, the debugger would stop on the index page loading, no break points were set. Same on a few other pages, but I just kept pressing F9 until it hit the breakpoints I had set in my extension code. It took many tries, but I finally found 1 bug and fixed it. Very grateful for the IDE showing me exactly where it was. I still have one extension I made that refuses to work, and it was driving me nuts so I walked away from things for a few days.

Today when I ran it, I was told I needed a trial activation code, which was supposed to give me 14 days. I activated it, it closed and came back "ok" as far as I knew. I loaded the forums software, it hit the same few places it did last time, including parts of my code, with no issues. After I went to login, it crashed with an error, so I closed everything down, nuked the IDE and wamp server, rebooted, loaded wamp again, loaded the IDE again, and started to debug again.

The main forums page loaded, again with breaking the same places as before.. still not sure why but whatever).. And when I went to "login", the IDE came back and told me I had used the 100 or whatever debug sessions and I had to buy it.

Huh? I've barely even begun to understand what this is all about. This is my first time trying anything like this and the learning curve is not friendly, but I thought I was getting somewhere finally.

Is there anything that can be done about this?

Thanks...
View user's profileFind all posts by dbsDevSend private message
Using with phpBB
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic