NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Vertical lines that display code indents


Joined: 03 Feb 2008
Posts: 30
Reply with quote
How can I make them less intrusive to my eyes?

I don't like all those vertical lines showing the indents - they make the code hard to read. Somehow in the last couple of days they started appearing. Previously, there were faint lines that showed, but now these bolder vertical lines are very annoying.

I guess this feature is called "indent guides". I found where to turn them on or off, but the settings for active and inactive don't appear to change the style - I always get "thick" obtrusive vertical lines no matter what color I choose.
View user's profileFind all posts by a_edwallSend private message


Joined: 27 Oct 2014
Posts: 9
Reply with quote
You mean that lines?

s017.radikal.ru/i412/1603/44/81cfe5f93504.png

Yes, they're called "indent giudes", and I can deactivate them at "Tools" - "Settings" - "Editor theme" - "Editor" - "Indent guides" (checkbox)
View user's profileFind all posts by todaySend private message
Guru master

Joined: 24 Jul 2009
Posts: 724
Reply with quote
When these guides were first implemented, some people noticed they were quite heavy and they could not change the style of them.

For other people such as myself the lines were faint and the settings did change the style.

At the time I guessed that some video adapters have some sort of issue with whatever method is used to draw these lines, but I don't know if that was ever confirmed as an issue or in any way changed/fixed.

Maybe that is the problem that a_edwall has?
View user's profileFind all posts by plugnplaySend private message


Joined: 09 Jan 2009
Posts: 29
Reply with quote
It is also my impression that it has something to do with the video driver. On my new laptop, the lines are very thick and annoying.

Maybe NuSphere can still optimize here.
View user's profileFind all posts by SvFrickeSend private message


Joined: 24 Mar 2016
Posts: 7
Reply with quote
I'm having the same problem for a long time. It appears on the systems with nVidia Optimus switchable graphics (Intel + nVidia). A lot of laptops are equipped with this technology. I've wrote about it to the NuSphere support, but they didn't help me to solve this issue.
View user's profileFind all posts by TwistedAndySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
v17 uses AlphaBlend() instead of TransparentBlt(), so the buggy graphics drivers (like one that comes with Intel i5/i7 built-in graphics) that have broken TransparentBlt() should work okay now.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Vertical lines that display code indents
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic