NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Profiler not working correctly (PHPED 16)


Joined: 12 May 2016
Posts: 6
Reply with quote
I'm trying to profile the behaviour of a complex shop system, where zillions of PHP-Modules and Classes are executed along the way.

But the profiler only shows a very, very tiny fraction of the PHP-Modules and Classes executed.

What can be wrong?

View user's profileFind all posts by AvengerSend private message
Guru master

Joined: 24 Jul 2009
Posts: 719
Reply with quote
I reported a profiler bug at around build 16050 and that was subsequently fixed but I don't know which build it was fixed in. Make sure you are using the latest v16 build.

Also, make sure you are using the correct DBG extension for the PhpED build, because there were changes in the DBG data formats.
View user's profileFind all posts by plugnplaySend private message


Joined: 12 May 2016
Posts: 6
Reply with quote
plugnplay wrote:
I reported a profiler bug at around build 16050 and that was subsequently fixed but I don't know which build it was fixed in. Make sure you are using the latest v16 build.

Also, make sure you are using the correct DBG extension for the PhpED build, because there were changes in the DBG data formats.
I have upgraded to Version 17, the Problem still persists. Sad
View user's profileFind all posts by AvengerSend private message
Guru master

Joined: 24 Jul 2009
Posts: 719
Reply with quote
I'm unfamiliar with your code so don't know what is missing from that view. I just profiled a request on a Magento (complex store) site and it looked correct; nothing obviously missing.

At the top of the Modules list is there a row called <<PHP Core>> ?

Do you see anything useful in the Functions or Lines views?

Did you update the PHP DBG extension on the web server after installing the new PhpED?
View user's profileFind all posts by plugnplaySend private message


Joined: 12 May 2016
Posts: 6
Reply with quote
plugnplay wrote:
At the top of the Modules list is there a row called <<PHP Core>> ?


No.

plugnplay wrote:
Do you see anything useful in the Functions or Lines views?


Yes, for the routines listed...

plugnplay wrote:
Did you update the PHP DBG extension on the web server after installing the new PhpED?
Yes.
View user's profileFind all posts by AvengerSend private message
Guru master

Joined: 24 Jul 2009
Posts: 719
Reply with quote
You probably need to report it as a possible bug.

I've been doing quite a bit of profiling with v17 and it has been working fine so far.
View user's profileFind all posts by plugnplaySend private message


Joined: 12 May 2016
Posts: 6
Reply with quote
plugnplay wrote:
You probably need to report it as a possible bug.

I've been doing quite a bit of profiling with v17 and it has been working fine so far.
Yes, I have submitted a bug report....
View user's profileFind all posts by AvengerSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
it looks like either a) you're using some sort of php opcode cache or b) it's what was actually executed and profiler reflected it or c) you tried to start profiler with DebugBreak(); Latter is not supported at all. You have to invoke the profiler from the IDE.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 12 May 2016
Posts: 6
Reply with quote
dmitri wrote:
it looks like either a) you're using some sort of php opcode cache or b) it's what was actually executed and profiler reflected it or c) you tried to start profiler with DebugBreak(); Latter is not supported at all. You have to invoke the profiler from the IDE.
a) No, using plain XAMPP.

b) No, this is not what is being executed. The debugger goes all the way how it should be.

c) Invocation via IDE does not help.

Strangely enough though:

if I profile e.g. PHPMyAdmin, the profiler behaves as expected...
View user's profileFind all posts by AvengerSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
if you're a phped PRO customer, you're entitled to contact support and sort out the problem.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Profiler not working correctly (PHPED 16)
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic