NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Windows 8 remote debugging issues


Joined: 26 Jan 2014
Posts: 15
Reply with quote
Hi,
even this settings has been established remote debugging with Windows 8 is not possible.
- allow dbglistener.exe to receive inbound connections on tcp/7869 port on your development machine
- allow debuger module to establish outbound connections on tcp/7869 port on your server.

Any ideas?
Thanks,
Otto
View user's profileFind all posts by ottovinzentSend private message
Guru master

Joined: 24 Jul 2009
Posts: 729
Reply with quote
Normally when you install PhpED it will add the firewall exceptions to the Windows Firewall for you. In fact, I just checked and it looks like it also adds an exception every time I do a PhpED update Shocked

Those settings can be adjusted in Windows Firewall Advanced settings and it looks like PhpED configures dbglistner.exe for all addresses, protocols and ports. PhpED probably does not configure any third-party firewalls.

Does PhpED work with the firewall(s) disabled? That will confirm if it is a firewall related issue.

Also check any anti-virus products. Some have protection systems that can interfere with communications. You may have to exclude dbglistener and/or phped from those systems.
View user's profileFind all posts by plugnplaySend private message
Windows 8 remote debugging issues


Joined: 26 Jan 2014
Posts: 15
Reply with quote
Thank you very much for your quick reply plugnplay.

We've no problems with all machines and port 7869 with remote debugging on Windows 7 machines. The only issues we permanently get are those I've described earlier with freezing of phped after remote timeouts. This might be very annoying but remote debugging generally is working on each machine.

A new installed Windows 8 machines gives us: port mapping error: 0x80004005 with Settings Wizard so that generally no remote debugging is possible Sad

We've checked antivirus software (no software installed) and firewall (deactivated) with the same behaviour Sad

Any further ideas or is generally remote debugging with Windows 8 not possible?

Thank you.
View user's profileFind all posts by ottovinzentSend private message


Joined: 26 Jan 2014
Posts: 15
Reply with quote
Update: We're now able to remote debug on Windows 8, it just seems to be a bug of Phped - whatever reason - but it's working! Smile

The wrong message permanently occurring is:
Debugger Failed to add UPnP port mapping: 7869 -> xxxxxxxxxx:7869, error (0x80040209)
View user's profileFind all posts by ottovinzentSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7887
Reply with quote
Port mapping is a featude that is supported by your router. It can be updated if router also supports uPnP protocol. If it does not, you'll see such messages. In this case just turn OFF uPnP in the listener settings and add port mapping in the router (check NAT settings page)

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 26 Jan 2014
Posts: 15
Reply with quote
the problem is that we have different situations, whatever reason. Most of the times such messages arrive even debugging is working. In another case such messages arrive and debugging is not possible. Restarting PhP solves the issue in the most cases. But there are cases where phped hangs and can only by killed by task manager. We also have seen no error messages and debugging was also possible (in a few cases).

The whole debugging system seems strange in our Windows 8 environment (we checked firewall and router issues without seeing any problems). Very often (normally every 2nd debugging session we're getting the following error messages:

DBG 7.5.3

Failed to start DBG session


Reason: failed to resolve client address "clienthost@clienthost" (ipv6 enabled: true)
Not sure what it means? Visit http://www.nusphere.com/dbg/?err=-3 for troubleshooting.
If you didn't intend to run debug session you may want to drop debugger cookie by clicking this button:

Debugger request: "@clienthost@clienthost:7869;d=1,p=0,c=1"
Request found in: "$_COOKIE['DBGSESSID']"
Target PHP version: "5.4.x"
Server API: "Apache 2.0 Handler"
Extensions API: "220100525"
Modules API: "20100525"
PHP API: "20100412"

___________________

Visiting http://www.nusphere.com/dbg/?err=-3 for troubleshooting doesn't helped.

Any ideas?
View user's profileFind all posts by ottovinzentSend private message
Guru master

Joined: 24 Jul 2009
Posts: 729
Reply with quote
Is that debugger request parameter correct?

Code:
Debugger request: "@clienthost@clienthost:7869;d=1,p=0,c=1"


It shows @clienthost twice. If the debugger parses from the first @ to the next : it would possibly be ending up with an invalid hostname or IP address.

According to the error, that is what is happening:

Code:
Reason: failed to resolve client address "clienthost@clienthost" (ipv6 enabled: true)


How do you instigate debug sessions and do your PHP applications do anything with query strings, such that a query error could propagate into the debugging session?

I've been using PhpED on Windows 8 (now 8.1) since it was released and never had an error like this.

When PhpED next hangs, try pressing the escape key. I have on occasion seen (or more precisely, not seen) hidden dialogs that are sitting behind the main PhpED window. I can't remember off-hand what causes it, there is something I posted in this forum about plus I think I also reported it as a bug. When that dialog is hidden, pressing escape discards it.

Update: Just checked and that hidden dialog sometimes happened when PhpED thought the project directory mapping was incorrect. Nothing to do with UPnP and port mapping, but at the time I suspected other dialogs could also be hidden. I also don't know if this problem was resolved or not, but I haven't seen it for a long time.
View user's profileFind all posts by plugnplaySend private message
Windows 8 remote debugging issues
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic