NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Bug Chrome Embedded Debugger trigerring "onblur" t


Joined: 31 Jan 2015
Posts: 2
Reply with quote
Hi
Using PHPED 15.0
Do you have the same bug ?
Just try the following php script and test is in the Chrome Embedded Debugger (Embedded Mozzilla and Embedded IE are giving good result)
By my side, if I start to press any key in the input text, the focus is instantely lost, trigerring then the "onblur" event. This is a really annoying bug.

<?php
if(isset($HTTP_GET_VARS['checkval'])) {
echo "it's good";
exit;
}
?>
<head>
<script src="http://ajax.googleapis.com/ajax/libs/jquery/1.9.0/jquery.min.js" type="text/javascript"></script>
<script type="text/javascript">
<!--
function check_value(val) {
$.ajax({
url: "/onblurtest.php?checkval=" + val,
async: false,
cache: false,
success: function (result) {
$('#response').html(result);
}
});
}
-->
</script>
</head>
<html>
<body>
<input name="keywords" type="text" value="Seach" onclick="this.value='';$('#response').html('');" onkeyup="check_value(this.value)" onblur="this.value='Search'" autocomplete="off" size>
<div id="response"></div>
</body>
</html>
View user's profileFind all posts by Nicolasmol76Send private message
Guru master

Joined: 24 Jul 2009
Posts: 729
Reply with quote
I created an empty onblurtest.php so that the Ajax worked then used your code; worked fine in embedded Chrome for myself. Didn't lose focus when I typed.

I do all of my browser debugging using external browsers, so I'm not familiar with issues that may exist in embedded browsers.

Bear in mind that some PhpED debug events could possibly cause focus to be lost, at least within the IDE. Is the Ajax causing a onblurtest.php to run in debug mode and causing the loss of focus? Does the problem occur when running the code in non-debug mode?
View user's profileFind all posts by plugnplaySend private message


Joined: 31 Jan 2015
Posts: 2
Reply with quote
The problem occurs ONLY in Chrome Emedded Browser ONLY during DEBUG session and yes, it's the ajax request which cause the loss of focus, but again the same ajax request does not cause a lost of focus in either IE or Mozzilla embedded browsers
View user's profileFind all posts by Nicolasmol76Send private message
Bug Chrome Embedded Debugger trigerring "onblur" t
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic