NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Debugger doesn't start


Joined: 19 Sep 2014
Posts: 5
Reply with quote
What did I find out about your system

I assume that you placed me in the root directory of your web server and on your PhpED machine pointed your browser to me - like this: <URL of your web site>/dbg-wizard.php

I see that:

PHP Version: 5.3.3
Web Server: Apache/2.2.15 (CentOS)
Server Name: dailydev.fiuze.com
Platform: Linux-glibc-2.12/x86_64
Your Client IP Address: 23.243.221.48
Your Server IP Address: 162.243.35.138
Port: 80
Your Web Server and PhpED are on different machines
Path to website files: /var/www/html/dailysale
Document Root is: /var/www/html/dailysale/
Your PHP.INI file is: /etc/php.ini
PHP extensions directory is: /usr/lib64/php/modules
DBG (PHP DEBUGGER) Version 6.1.4 is INSTALLED

[menashe@dailysale ~]$ telnet 127.0.0.1 7869
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.

(so i can telnet into my dev comp through port forward)

And the message is in the Log window of PhpED:

Debugger client disconnected, An operation was attempted on something that is not a socket. 12:08:00 PM

Any idea what that means?
View user's profileFind all posts by kemenytelSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Check SELinux settings. It should allow apache process to connect to the outbound addresses using debugger's port (7869/TCP by default).
And by default SELinux prohibits such connections.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Debugger doesn't start


Joined: 19 Sep 2014
Posts: 5
Reply with quote
Rolling Eyes
Dmitri, kak dyela?

That can't be my problem, since as I said, i was able to telnet to localhost on the server, see in the first post.
The issue must be on win7 side, i just can't guess what.
View user's profileFind all posts by kemenytelSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
before proceed any further, please learn what SELinux is about and why it may allow some connections and prohibit others.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 19 Sep 2014
Posts: 5
Reply with quote
dmitri wrote:
before proceed any further, please learn what SELinux is about and why it may allow some connections and prohibit others.


and with that we arrived at the problem. After a month, that's the level of thought given. Very nice.

So let's check SELinux, shan't we?

[menashe@dailysale ~]$ sestatus
SELinux status: disabled

Oh, no?! It is disabled. That should not be possible, that has to be the reason. Even though i connected to the port through telnet, correct?
Not maybe a Win7 listener issue,no. It's SELinux.

Dmitri, please, i am a paying customer, I would expect a stronger look before answering like that.
???????
View user's profileFind all posts by kemenytelSend private message


Joined: 19 Sep 2014
Posts: 5
Reply with quote
dmitri wrote:
before proceed any further, please learn what SELinux is about and why it may allow some connections and prohibit others.


and with that we arrived at the problem. After a month, that's the level of thought given. Very nice.

So let's check SELinux, shan't we?
Code:

[menashe@dailysale ~]$ sestatus
SELinux status:                 disabled


Oh, no?! It is disabled. That should not be possible, that has to be the reason. Even though i connected to the port through telnet, correct?
Not maybe a Win7 listener issue,no. It's SELinux.

Dmitri, please, i am a paying customer, I would expect a stronger look before answering like that.
???????
View user's profileFind all posts by kemenytelSend private message


Joined: 19 Sep 2014
Posts: 5
Reply with quote
dmitri wrote:
before proceed any further, please learn what SELinux is about and why it may allow some connections and prohibit others.


and with that we arrived at the problem. After a month, that's the level of thought given. Very nice.

So let's check SELinux, shan't we?
Code:

[menashe@daxxxxxe ~]$ sestatus
SELinux status:                 disabled


Oh, no?! It is disabled. That should not be possible, that has to be the reason. Even though i connected to the port through telnet, correct?
Not maybe a Win7 listener issue,no. It's SELinux.

Dmitri, please, i am a paying customer, I would expect a stronger look before answering like that.

Code:

???????
View user's profileFind all posts by kemenytelSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
This is not a support service. Please re-read the forum rules.
If you're a paying customer, please use correct way of submitting issues -- http://www.nusphere.com/contact_us/

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Debugger doesn't start
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic