NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
slowing down inserting lines in the middle of debugging


Joined: 01 Aug 2014
Posts: 14
Reply with quote
Hi all,

Does anyone else have the same problem with dbg v7.0.25/v14:

When in the middle of debugging session inserting lines ABOVE the current execution line is nearly killing IDE. A single carriage return keypress may take up to a second or two to execute. Pasting a block of text above execution line simply freezes IDE and lines are inserted EXTREMELY slow and that part of the screen looks like a mess.

Thanks!
View user's profileFind all posts by temuri416-v2Send private message
Guru master

Joined: 24 Jul 2009
Posts: 723
Reply with quote
Yes, I have seen that problem. I'm using remote desktop for most of my PhpED work, so I wasn't sure if that had something to do with it.

Whilst PhpED does get there and visually the editor works fine, if I insert or delete lines then it takes a second for each line to be displayed. If a debug session is not running, it is instant.

Do you use remote desktop?
View user's profileFind all posts by plugnplaySend private message


Joined: 01 Aug 2014
Posts: 14
Reply with quote
Nope. I'm local. Since inserting lines after current execution line is fine, it points to a fresh bug.

Cheers.
View user's profileFind all posts by temuri416-v2Send private message


Joined: 01 Aug 2014
Posts: 14
Reply with quote
Also, if you keep hitting Enter quickly enough (above the execution point), a confirmation prompt appears with the following message: "Do you really want to cancel operation ?" Yes/No. No mentioning of the operation, though Smile
View user's profileFind all posts by temuri416-v2Send private message


Joined: 16 Aug 2008
Posts: 29
Reply with quote
It has nothing to do with remote desktop. I never used it and I'm experiencing this too. I "solved" it by writing whatever i want to write to Trello and then getting back to it someday.
View user's profileFind all posts by odinuvSend private message
Guru master

Joined: 24 Jul 2009
Posts: 723
Reply with quote
Sort of shows the value of sharing problems through the forum. There I was thinking it was a remote desktop issue and now 3 of us have the same problem and it is probably nothing to do with remote desktop.

I think this is at least partially an IDE issue, not a debugger issue. In my testing I found that editing in a position after a breakpoint was full speed, before a breakpoint was slow. Turning off the breakpoint without resuming execution, so still debugging, then also got the editing back to full speed, so it appeared to be related to changing the display position of the breakpoint during a debug session. I've reported this to NuSphere.
View user's profileFind all posts by plugnplaySend private message


Joined: 16 Aug 2008
Posts: 29
Reply with quote
plugnplay wrote:

I think this is at least partially an IDE issue, not a debugger issue. In my testing I found that editing in a position after a breakpoint was full speed, before a breakpoint was slow. Turning off the breakpoint without resuming execution, so still debugging, then also got the editing back to full speed, so it appeared to be related to changing the display position of the breakpoint during a debug session. I've reported this to NuSphere.


That sounds plausible, it certainly isn't slow everytime. I didn't observe it so much, but I distinctively remember that correcting a comment for a method being debugged is slow (which supports your point - the comment is above the breakpoint).
View user's profileFind all posts by odinuvSend private message


Joined: 07 May 2014
Posts: 63
Reply with quote
@dmitri

The problem occurs regardless whether cursor is above or below execution point.

Inserting lines ALWAYS get stuck if you have at least one debugbreak in the IDE below the cursor position.

Hope this helps. This particular issue has become quite a pain.
View user's profileFind all posts by temuri416Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
seems somebody has very little patience to read the messages

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 07 May 2014
Posts: 63
Reply with quote
sorry, I do not understand what you mean by that.

I am just trying to do my best to explain the problem so it's easy to reproduce. I did submit a bug report last week as well.

Would you like me to do something different?

Thanks.
View user's profileFind all posts by temuri416Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
it about BREAKPOINTS.
ALL of them in the current file.
Position of the execution point plays no role.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 07 May 2014
Posts: 63
Reply with quote
Exactly. That's what I said last. If there are breakpoints below the line where you're inserting a carriage return - the IDE will become unresponsive and insertion will take roughly a second per newly inserted line break.

It does not matter whether current execution line is above or below the place where you paste multiline text block or press Enter.

Can something be done about it?

I have this issue reported as well via Contact Us form.

Thanks.
View user's profileFind all posts by temuri416Send private message
slowing down inserting lines in the middle of debugging
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 3  

  
  
 Reply to topic