NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Incorrect icons on many files [resolved]


Joined: 23 Jun 2008
Posts: 32
Reply with quote
Hello,

I'm struggling with incorrect file icons in PhpEd. In Windows Explorer (and in every other application) file icons are correct.

When I open PhpEd at first correct icons are shown, but then incorrect ones are drawn on top of the correct icons. So files do have two icons on top of each other. It's not even the same incorrect icon drawn on top of files every time I open PhpEd, but it's same icon on every file.
Any ideas what might be causing this?

This seems to happen more with projects with lot of files.



I filed a bug report, but NuSphere's answer was this is not a bug and I should check every other application installed on my system.
View user's profileFind all posts by AirspraySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Not every other, but only the ones that work as Shell Extension (integrated into Windows Shell)
You can start with HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\ShellIconOverlayIdentifiers
You will find GUIDs there that refer to DLLs in HKEY_
For example in case of Tortoise SVN I see {C5994564-53D9-4125-87C9-F193FC689CB2} under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ShellIconOverlayIdentifiers\5TortoiseReadOnly
and this GUID is used by TortoiseOverlays.dll in HKEY_CLASSES_ROOT\CLSID\{C5994564-53D9-4125-87C9-F193FC689CB2}\InProcServer32

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 23 Jun 2008
Posts: 32
Reply with quote
Thank you for your reply. I'll investigate further with this.
View user's profileFind all posts by AirspraySend private message


Joined: 23 Jun 2008
Posts: 32
Reply with quote
Turns out so many programs wanted to add overlay icons that (maybe) the indexes had doubles.

There is a bunch of things to try (I had to do all of them) and you can find them here: http://stackoverflow.com/questions/2217880/windows-explorer-icons-in-tortoisesvn-take-a-long-time-to-refresh-to-correct-sta

I hope this helps someone.
View user's profileFind all posts by AirspraySend private message
Incorrect icons on many files [resolved]
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic