NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
v19536 Personal is so slow starting up - why?


Joined: 03 Feb 2008
Posts: 39
Reply with quote
It seems that v19536 Personal is so much slower starting up than previous versions. Does anyone know why?

I don't upgrade each new release so I'm not sure this situation first appeared in v19536, but it is definitely slower to start than what my previous version was.

Thank you.

UPDATE: when starting up from a hibernate or computer OFF condition, it takes between 30 seconds and 60 seconds for PhpED to load. See the attached - what is it doing during this time?

P.S. I tried to attach a .jpg file and I get this error message:
Bad Request
Your browser sent a request that this server could not understand.

The image says "Starting up . . . " and has the copyright info, the "19 PERSONAL" version number and type. 19.5 (Build 19536, 64bit).
View user's profileFind all posts by a_edwallSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8239
Reply with quote
It's known that sometimes some antiviruses use shared world-wide DB about running software and it take time for them to settle with new software they are checking. If that's the case just wait a few more weeks or replace your antivirus.
We didn't change anything in 19536 that would affect startup time or make it working slower.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 18 Dec 2021
Posts: 10
Reply with quote
Hi!
I got the same problem exactly starting from last build 195369. About (or also more) 1 minute is needed to use the editor.
My only antivirus is Windows defender.
Ciao!
View user's profileFind all posts by p_pippoloSend private message


Joined: 18 Dec 2021
Posts: 10
Reply with quote
Hi!
Starting from last update (19538), the problem appears to have been solved.
Well, great job! Smile
View user's profileFind all posts by p_pippoloSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8239
Reply with quote
Concerning performance we didn't change anything before 19536 to slow it down and we didn't make any changes in 19538 to make it any faster.
I still think it's kind of interference with some other tools on your machine, most likely AV.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 18 Dec 2021
Posts: 10
Reply with quote
My machine, my OS and so on, are exactly the same Smile
Maybe something went wrong in the previous installation, but it didn't show any errors.
However, the important thing is that everything is working fine now.
Thanks for the great job!
View user's profileFind all posts by p_pippoloSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8239
Reply with quote
Right, same OS, same the other software, but software may work differently -- such as AV heuristic algorithms, false positives etc. If they put a software into sandbox, it's expected to work slower. Also, I have to add that PhpED is sensitive to free memory amount and CPU availability. You know, these days browsers are very aggressive in their RAM and CPU demand. Finally, some Ads in the internet are using CPU too much. So it would be enough to open such page and experience significant slowdown in PhpED.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 18 Dec 2021
Posts: 10
Reply with quote
I would agree if the problem solved itself, instead is solved just after the very latest version of Nusphere was installed.
However, the important thing is that everything is working fine now. Smile
View user's profileFind all posts by p_pippoloSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8239
Reply with quote
yeah, I see no problems understanding that Smile
I'm glad it's resolved now.
Just in case if it re-appear again, try to check what's going on in the system - like CPU utilization, RAM pressure, may be your AV can show what apps are sandboxed etc. Sometimes it's enough to just close all browser windows then kill remaining browser processes in the Task Manager app on processes tab. I mean you don't have to wait for our updates.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 18 Dec 2021
Posts: 10
Reply with quote
Maybe with my bad English I didn't explain myself well.
The problem arose with the installation of the previous update (19536), and the problem of the long loading (at least one minute) of PhpED occurred "every time" it was run.
The problem was solved by installing the latest update (19538), in fact now the program works well "every time" I run it, that is, as it worked before 19536.
Between the previous update (19536) and the last one (19538), my computer (Windows 8, AMD A8, 8GB RAM, 1TB HD) hasn't changed and has always done the same things as always: mail, writing and programming.
I hope I have better explained what happened Smile
View user's profileFind all posts by p_pippoloSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8239
Reply with quote
Ok, sounds like the problem was persistent. Did you reboot your computer at the times when you used 19536? If you did, it's very unlikely that the problem caused by a browser demanding too much CPU and RAM, but still does not make invalid the theory about sandbox.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 18 Dec 2021
Posts: 10
Reply with quote
I turn my computer on and off several times a day, I don't always keep it on!
View user's profileFind all posts by p_pippoloSend private message
v19536 Personal is so slow starting up - why?
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 2  

  
  
 Reply to topic