NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[resolved] Use different debug port for each server


Joined: 23 Jun 2008
Posts: 13
Reply with quote
Hello,

Currently i'm using phped remote debugging on 3 different servers (ssh tunneling to each of them).

My question is the following: right now i use option "Use custom port and host" (from settings->ide->Run&debug->Default debugger setting). Since it's called "Default debugger setting" i was thinking that there is the way to change this value for each project. I.e. set project A to debug at 7869, B->7870 and so on. Is it possible? Otherwise i can't keep putty opened for each server, and i'm forced to change "Use custom port and host" setting each time i switch project.

Thx in advance.


Last edited by Alekc on Tue Jun 24, 2008 4:43 am; edited 1 time in total
View user's profileFind all posts by AlekcSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
Looks like there is a stupid limitation in putty. It should have no problems with opening the same listening sockets on different remote machines.
Please try to run multiple instances, each with its own active tunnel.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 23 Jun 2008
Posts: 13
Reply with quote
UHm my bad, actualy it seems to be working with 2 o more putty opened together. I thought that it was impossible to stay in listening on the same port for multiple process...

Issue solved Smile
View user's profileFind all posts by AlekcSend private message
[resolved] Use different debug port for each server
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic