NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[resolved] Unable to locate LIBPQ.dll in 5236/5237 build


Joined: 13 Oct 2007
Posts: 9
Location: Kirkland, Wa
Reply with quote
Error message comes up, indicating it's missing the library and that the app may need to be reinstalled to function correctly.

This fails on all internal and external browsers. It seems to show the error dialog every time it would've gone to show debugger text (although I'm not trying to run it in debugger). In other words it seems to show as many times as the source code would've shown up if debugger was used. Hope this helps.

As it is - it's impossible to test anything from the IDE due to a ton of these requesters all being dialog pop-ups forcing clicking on OK just to close that instance.

Any help would be appreciated, since as is - PhpEd is pretty much unusable.

Thanks.

_________________
RS
View user's profileFind all posts by RecordSageSend private messageMSN Messenger


Joined: 04 Jul 2007
Posts: 5
Reply with quote
this is due to the pgsql extention. you're getting this if you don't have pgsql installed on your system.
workaround: disable the loading of the pgsql extension if you dont need it.
fix: copy LIBPQ.dll into the php5 directory (or %windir%/system).
View user's profileFind all posts by caloriferSend private message
Why?


Joined: 13 Oct 2007
Posts: 9
Location: Kirkland, Wa
Reply with quote
This has never been an issue before (well, before 5236). I'm not using Postgres... makes no sense.

_________________
RS
View user's profileFind all posts by RecordSageSend private messageMSN Messenger


Joined: 04 Jul 2007
Posts: 5
Reply with quote
this is an issue with the pgsql extension shipped with php 5.2.6
http://bugs.php.net/bug.php?id=44905
View user's profileFind all posts by caloriferSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
that's correct.
To workaround the problem please install php from the link posted there
problem-with-postrgress-library-libpq-dll-in-build-5236-t4847.html#19925#19950

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
That did it! :)


Joined: 13 Oct 2007
Posts: 9
Location: Kirkland, Wa
Reply with quote
Thank you!!!

_________________
RS
View user's profileFind all posts by RecordSageSend private messageMSN Messenger
[resolved] Unable to locate LIBPQ.dll in 5236/5237 build
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic