NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
The debugger periodically does not open any ports


Joined: 27 Feb 2011
Posts: 19
Reply with quote


Why i have such problem?

PHPed ver

View user's profileFind all posts by MirocowSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
What _problem_ do you encounter, besides that some tool does not show something?

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 27 Feb 2011
Posts: 19
Reply with quote
debugger dose not open any ports
View user's profileFind all posts by MirocowSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
this is not a problem. I know many programs that does never open any ports.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 07 Jun 2007
Posts: 62
Location: Albuquerque, NM, USA
Reply with quote
I run into this every few times opening/closing PhpED too, also x64, v12.0 build 12021 (latest as of this posting).

My solution/work around fix is to close PhpED, kill the DbgListener.exe, give it a few minutes, and re-start PhpEd, then it usually works properly.

when this happens, the "log" tab in PhpED shows "Starting DbgListener..." in RED vs in black when it works properly.

this is definitely a real problem as the dbglistener has to listen on ports in order to work properly, specially remotely, which is what I use all the time.

Also, this same version has crashed on me once a day for 3 days in a row now, while simply typing out code in a file (PHP), very odd for PhpED to crash.
View user's profileFind all posts by skalirSend private messageVisit poster's websiteAIM AddressYahoo MessengerICQ Number


Joined: 07 Jun 2007
Posts: 62
Location: Albuquerque, NM, USA
Reply with quote
Furthermore, to confirm @Mirocow initial post here, here's some screen shots from my side from this happening just right now, you'll see the 6 copies of DbgListener.exe running (when I close phped, it NEVER properly closes down the DbgListener.exe with it), also you'll see the ports showing open when its working below too, and the RED vs BLACK "Starting DbgListener" notice in the screen shots too.

NOT LISTENING/DEBUGGER DOES NOT WORK





DEBUGGER IS LISTENING, WORKS FINE


View user's profileFind all posts by skalirSend private messageVisit poster's websiteAIM AddressYahoo MessengerICQ Number


Joined: 27 Feb 2011
Posts: 19
Reply with quote
i don`t have any copies of DbgListener.exe
I check it
But when i start PHPEd i haven`t open ports in DbgListener.exe then PHPed dosen`t listen it

This is mega BUG
View user's profileFind all posts by MirocowSend private message


Joined: 27 Feb 2011
Posts: 19
Reply with quote
the problem started after 11 version
View user's profileFind all posts by MirocowSend private message


Joined: 27 Feb 2011
Posts: 19
Reply with quote


And now i have
View user's profileFind all posts by MirocowSend private message


Joined: 27 Feb 2011
Posts: 19
Reply with quote
But when it`s work

we can see such

View user's profileFind all posts by MirocowSend private message


Joined: 27 Feb 2011
Posts: 19
Reply with quote
Mirocow wrote:
But when it`s work

we can see such

View user's profileFind all posts by MirocowSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
Hey guys, if you have anything real to report and you want to help _us_, please do this properly - using Contact Us form.
This forum is for the case if you expect anybody else to help you (possibly with settings or somehow else).

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
The debugger periodically does not open any ports
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 2  

  
  
 Reply to topic