NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Switching from PHP 5 to PHP 7


Joined: 05 Aug 2017
Posts: 1
Reply with quote
I've just changed the PHP version from PHP 5.3 through 5.6 to PHP 7.x in the IDE (Run & Debug -> Settings and Code Insight ->Settings) but when I start typing anything that is derived from mysqli code completion isn't working. I get a message saying that code completion is not available - Failed to find "mysqli" class (or trait). If I switch back to PHP 5.3 through 5.6 code completion works. The PHP script works fine (connects to the database and runs SQL) for both versions of PHP so something is finding the mysqli code.
View user's profileFind all posts by DementedGibbonSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
it works fine for me

It you are still having problem, update IDE to the latest version and give parser time to re-parse all standard definitions.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Switching from PHP 5 to PHP 7
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic