NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
I saw such images, not sure how to help though.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
flickering


Joined: 09 Jun 2012
Posts: 21
Reply with quote
Hi,

Many thanks for your work to test to try and replicate these issues Dimitri. I have updated my drivers to the latest revision and still notice that the highlighting boxes, indentation lines and collapsable boxes are still flickering whilst inputting text. This was not the case prior to phped v13.

Perhaps rather than just stating 'the flickering is still there' and hoping that the engineers at nusphere can determine what might be causing this, something like the output from dxdiag would be helpful?

I run win7 64x, with an asus branded amd EAH5450 Series video card running the latest version of the catalyst drivers 14.4 using eyefinity for multimonitor support running at 60mhz.

Please let me know if you feel this issue still warrants investigation and how I might be able to assist.

Again many thanks

Matthew
View user's profileFind all posts by mteejay101Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
My answer was about the following:
Estigy wrote:
And it seems that the theming color options for the indent guides seem not to work.
No matter what (light) color I choose, they always are rendered black.


and the following:
waynes wrote:
It does work but not as one would expect. Changing the color seems to change the background color of the dots, not the color of the dots which is what I would have expected. I was also excited about this feature but turned it off pretty quickly as it is too heavy and distracting. Prefer to have it a very light color so that it is not that obvious.


These troubles are due to bugs in graphics drivers implemented TransparentBlt in a wrong way.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 21 Nov 2009
Posts: 38
Reply with quote
dmitri wrote:
My answer was about the following:
Estigy wrote:
And it seems that the theming color options for the indent guides seem not to work.
No matter what (light) color I choose, they always are rendered black.


and the following:
waynes wrote:
It does work but not as one would expect. Changing the color seems to change the background color of the dots, not the color of the dots which is what I would have expected. I was also excited about this feature but turned it off pretty quickly as it is too heavy and distracting. Prefer to have it a very light color so that it is not that obvious.


These troubles are due to bugs in graphics drivers implemented TransparentBlt in a wrong way.


Dmitri, I disagree that it is a bug in the graphics driver. I am using a fairly new laptop with the latest drivers and not experiencing any problems in any other application. As a designer I use graphics intensively so I would know if I had a bug, but if as you say, its a bug with the graphics card, then there are going to be thousands of people using Nvidia GeForce GT 630 graphics cards that are going to affected, not to mention the graphic cards of the others in this thread that are affected by this issue. I understand and respect the fact that different screens and different graphic cards do display differently and you can't possibly cater for everyone, but that does not mean this issue is a bug in a graphics card. Nor does it mean there is a bug in your code but perhaps you could look for a method that is a little more compatible so that it works faultlessly across a wider range of graphic cards? You have mentioned it works across multiple OS platforms but have you tested multiple hardware platforms? I am happy not to use this feature for now as I don't have the flickering others mention, only the dark & heavy indent lines, but as a long standing paid up supporter of you product (since v4) I have seen many improvements to the product and resolutions to issues so I am sure you can find a better way to do this.....
View user's profileFind all posts by waynesSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
It is not our software changes the color for the lines when you select different anti-aliasing modes for the font. That's it. All other reasoing is irrelevant. You can disagree, but you can't explain why otherwise the same code works fine in other machines, including real and virtual. No machines I could find here exposed any problems with indent guide colors. We checked different cards - ATI, NVidia, S3, Intel (embedded into cpu), under different OSes, under different color settings. No problems at all. It must be something wrong with your machine.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 10 Apr 2014
Posts: 52
Reply with quote
Thought i would chime in here. I am also running the Nvidia GeForce GT 630 video card in my system and have no issues with the indent guides or flickering, etc. My OS is Win8.1 with an I7 cpu on a gigabyte motherboard.
View user's profileFind all posts by probc2Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
what I have is also NVidia, although a bit outdated:
Driver: NVIDIA
Version: 6.14.13.2101
Signer: Microsoft Windows Hardware Compatibility Publisher
and I checked under W xp32, xp64, w7/32, w7/64, w8/64 and w8.1/64

As of flicker, it may appear if you turn on Word Wrap, add some folded regions (collapsed text), adjust resolution to highest level to see more lines of text at once.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 10 Apr 2014
Posts: 52
Reply with quote
Ah nuts. I lied. Turns out i have the GT640 video card. Driver version is 9.18.13.3523.

I dont personally use word wrap, but i turned it on to try it out. Still no flickering or issues that i can see.
View user's profileFind all posts by probc2Send private message
Guru master

Joined: 24 Jul 2009
Posts: 710
Reply with quote
During Beta I tested this PhpED feature on AMD FirePro, VMware SVGA (Remote Desktop), NVidia GeForce GT 555M and NVidia Quadro NVS 160M. None of them have any apparent issues with setting colour of Indent guides; I've set both the Active and Inactive guides quite light using the Default theme.

I've also tested with Carbon theme using 20pt text; when I changed the colour of the guides it changed the colour of the 'dots' (actually small dashes as that size) and it worked fine. Certainly didn't change the colour of the background rather than the dots.

I do see a slight flicker in the lines when editing text, but what I see myself is at a level that I would consider expected and most acceptable for an editor display refresh.

I dare say other Beta testers have a variety of different hardware as well.
View user's profileFind all posts by plugnplaySend private message


Joined: 31 May 2014
Posts: 15
Reply with quote
waynes wrote:
I will log a bug report with images.


how can I log bug report with images?
thanks in advance.
View user's profileFind all posts by tntc4Send private message
Guru master

Joined: 24 Jul 2009
Posts: 710
Reply with quote
You can use this form to contact NuSphere Support
http://www.nusphere.com/contact_us/
View user's profileFind all posts by plugnplaySend private message


Joined: 31 May 2014
Posts: 15
Reply with quote
plugnplay wrote:
You can use this form to contact NuSphere Support
http://www.nusphere.com/contact_us/



but I want to show them some images/screenshots from my computer when sending bug report.
how to do this?
View user's profileFind all posts by tntc4Send private message
Suggestions to improve Indent guides
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 2 of 3  

  
  
 Reply to topic