NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
some bugs and glucks of TP 4.0 for w32


Joined: 14 Sep 2005
Posts: 1
Reply with quote
1. mod_perl does't work

C:\Program Files\NuSphere\TechPlat\apache\conf>..\apachectl.exe start
apachectl.exe start: httpd could not be started

C:\Program Files\NuSphere\TechPlat\apache\conf>..\apachectl.exe configtest
Syntax error on line 176 of c:/program files/nusphere/techplat/apache/conf/httpd.conf:
Cannot load c:/program files/nusphere/techplat/apache/modules/mod_perl.so into server: (126) Le module specifie est introuvable:

Note the errors or messages above, and press the <ESC> key to exit. 25...

line176:
LoadModule perl_module modules/mod_perl.so

2. some links is bad. For example
file:///C:/Program%20Files/NuSphere/TechPlat/manual/php/php_manual_en.chm
on page https://localhost:9443/doc_index.shtml

3. on page https://localhost:9443/admin_index.shtml we see text:
Quote:
There are no Administration applications installed.
# You can install the following Administration applications from the NuSphere distribution: WEBMIN System Administrator (Linux/Unix only)
# phpMyAdmin - a MySQL Data Dictionary written in PHP
# phpPgAdmin - a PostgreSQL Data Dictionary written in PHP

but I can't
Quote:
install the following Administration applications
from installation application
4. On the page http://www.nusphere.com/ writed
Quote:
NuSphere TechPlatform 3.4 for Windows
, but I can not found this version. Only 4.0 accessible, but don't work.

Thanks for you advice.

_________________
galerie.arsenalrusse.com
View user's profileFind all posts by zalexSend private messageICQ Number
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Quote:
Note the errors or messages above, and press the <ESC> key to exit. 25

You probably did not reboot after TP was installed. You have to do so, or mod_perl won't find perl.exe.
There is also another reason that may cause the problem. If you already have perl installed on your machine, it might be used by mod_perl if its path appears first in the %PATH% variable and if it is incompatible with mod_perl, latter one will fail to load. Just run perl -V and check perl's version number.

Quote:
some links is bad. For example
file:///C:/Program%20Files/NuSphere/TechPlat/manual/php/php_manual_en.chm
on page https://localhost:9443/doc_index.shtml

Make sure file is there. Also check IE security settings.

Quote:
but I can't install the following Administration applications from installation application

Sorry these packages aren't available with TP 4.0
View user's profileFind all posts by dmitriSend private messageVisit poster's website
some bugs and glucks of TP 4.0 for w32
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic